Hi Jeff,
 
Thanks for the reply.  I built 1.2.2 with configure/make/make install.
but I built 1.2.7 with the srpm.  Perhaps I will try the tar file.
 
Thanks,
Joe
 


From: users-bounces@open-mpi.org on behalf of Jeff Squyres
Sent: Wed 10/1/2008 5:35 PM
To: Open MPI Users
Subject: Re: [OMPI users] 1.2.2 to 1.2.7 differences.

Joe -- AFAIK, we didn't change anything with regards to OPAL_PREFIX in 
the 1.2 series.  Here's my tests on a 1.2.7 installation:

-----
[17:34] svbu-mpi:/home/jsquyres/openmpi-1.2.7 % head config.log
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Open MPI configure 1.2.7, which was
generated by GNU Autoconf 2.61.  Invocation command line was

   $ ./configure --prefix=/tmp/bogus

## --------- ##
## Platform. ##
[17:34] svbu-mpi:/home/jsquyres/openmpi-1.2.7 % /tmp/bogus/bin/mpirun -
np 2 uptime
  17:34:06 up 42 days, 23:36,  4 users,  load average: 0.57, 1.22, 0.79
  17:34:06 up 42 days, 23:36,  4 users,  load average: 0.57, 1.22, 0.79
[17:34] svbu-mpi:/home/jsquyres/openmpi-1.2.7 % mv /tmp/bogus /tmp/
bogus-foo
[17:34] svbu-mpi:/home/jsquyres/openmpi-1.2.7 % setenv OPAL_PREFIX /
tmp/bogus-foo
[17:34] svbu-mpi:/home/jsquyres/openmpi-1.2.7 % setenv 
LD_LIBRARY_PATH /tmp/bogus-foo/lib
[17:34] svbu-mpi:/home/jsquyres/openmpi-1.2.7 % /tmp/bogus-foo/bin/
mpirun -np 2 uptime
  17:34:47 up 42 days, 23:37,  4 users,  load average: 0.80, 1.19, 0.80
  17:34:47 up 42 days, 23:37,  4 users,  load average: 0.80, 1.19, 0.80
-----


On Sep 30, 2008, at 3:33 PM, Joe Griffin wrote:

> Hello All,
>
> My OpenMPI 1.2.2 version works fine.   I think OPAL_PREFIX has 
> changed.  I install from RPM with --prefix.  When I run with 1.2.7 I 
> get the error:
>
> [em64t6:23450] [NO-NAME] ORTE_ERROR_LOG: Not found in file runtime/
> orte_init_stage1.c at line 182
> --------------------------------------------------------------------------
> Sorry!  You were supposed to get help about:
>     orte_init:startup:internal-failure
> from the file:
>     help-orte-runtime
> But I couldn't find any file matching that name.  Sorry!
>
>
> I tried just running MPI run
>
> em64t6 <82> setenv LD_LIBRARY_PATH /usr/local/openmpi-1.2.7/lib64/
> em64t6 <83> setenv OPAL_PREFIX /usr/local/openmpi-1.2.7
> em64t6 <84> /usr/local/openmpi-1.2.7/bin/mpirun --help
> --------------------------------------------------------------------------
> Sorry!  You were supposed to get help about:
>     orterun:usage
> from the file:
>     help-orterun.txt
> But I couldn't find any file matching that name.  Sorry!
> --------------------------------------------------------------------------
>
>
> The file exists, so I think my OPAL_PREFIX that worked in 1.2.2 does 
> not seem
> to work like 1.2.7:
>
> em64t6 <85> ls -l $OPAL_PREFIX/share/openmpi/help-orterun.txt
> -rw-r--r--  1 root root 5718 Sep 29 07:23 /usr/local/openmpi-1.2.7/
> share/openmpi                                                /help-
> orterun.txt
>
>
> The above works with 1.2.2.  I searched the DOC and MAN pages for 
> OPAL_PREFIX, but could
> not find anything.   Can someone please tell me what has changed?   
> I am including opmi_info for completeness:
>
>
> em64t6 <93> /usr/local/openmpi-1.2.7/bin/ompi_info
>                 Open MPI: 1.2.7
>    Open MPI SVN revision: r19401
>                 Open RTE: 1.2.7
>    Open RTE SVN revision: r19401
>                     OPAL: 1.2.7
>        OPAL SVN revision: r19401
>                   Prefix: /usr/local/openmpi-1.2.7
>  Configured architecture: x86_64-redhat-linux-gnu
>            Configured by: root
>            Configured on: Mon Sep 29 07:15:16 PDT 2008
>           Configure host: em64t6
>                 Built by: root
>                 Built on: Mon Sep 29 07:23:22 PDT 2008
>               Built host: em64t6
>               C bindings: yes
>             C++ bindings: yes
>       Fortran77 bindings: yes (all)
>       Fortran90 bindings: no
>  Fortran90 bindings size: na
>               C compiler: gcc
>      C compiler absolute: /usr/bin/gcc
>             C++ compiler: g++
>    C++ compiler absolute: /usr/bin/g++
>       Fortran77 compiler: g77
>   Fortran77 compiler abs: /usr/bin/g77
>       Fortran90 compiler: none
>   Fortran90 compiler abs: none
>              C profiling: yes
>            C++ profiling: yes
>      Fortran77 profiling: yes
>      Fortran90 profiling: no
>           C++ exceptions: no
>           Thread support: posix (mpi: no, progress: no)
>   Internal debug support: no
>      MPI parameter check: runtime
> Memory profiling support: no
> Memory debugging support: no
>          libltdl support: yes
>    Heterogeneous support: yes
>  mpirun default --prefix: no
>            MCA backtrace: execinfo (MCA v1.0, API v1.0, Component 
> v1.2.7)
>               MCA memory: ptmalloc2 (MCA v1.0, API v1.0, Component 
> v1.2.7)
>                MCA timer: linux (MCA v1.0, API v1.0, Component v1.2.7)
>          MCA installdirs: env (MCA v1.0, API v1.0, Component v1.2.7)
>          MCA installdirs: config (MCA v1.0, API v1.0, Component 
> v1.2.7)
>
> Can someone please tell me what has changed?
> Regards,
> Joe Griffin
>
> _______________________________________________
> users mailing list
> users@open-mpi.org
> http://www.open-mpi.org/mailman/listinfo.cgi/users


--
Jeff Squyres
Cisco Systems

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users