Ralph,

Thanks!
I checked output of "ompi_info" and found that OpenMPI on PowerPC is not built with heterogeneous support. We will rebuild OpenMPI and then try the command you suggested.

Best Regards,
Mi
Inactive hide details for Ralph Castain <rhc@lanl.gov>Ralph Castain <rhc@lanl.gov>


          Ralph Castain <rhc@lanl.gov>
          Sent by: users-bounces@open-mpi.org

          08/20/2008 12:53 PM
          Please respond to
          Open MPI Users <users@open-mpi.org>


To

Open MPI Users <users@open-mpi.org>

cc


Subject

Re: [OMPI users] run OpenMPI job on heterogeneous processor

First, I trust that you built Open MPI to support heterogeneous  
operations? I'm not sure what version you are using, but it may well  
have done it by default.

Second, there is an error on your cmd line that is causing the  
problem. It should read:

mpirun -np 1 -host b1 foo_x86 : -np 1 -host b2 foo_ppc

The way you wrote it, foo_x86 will run anywhere it wants (which would  
default to whatever node you were on when you executed this), while  
foo_ppc will run on both hosts b1 and b2 (which means the first rank  
will always go on b1).

Hope that helps
Ralph


On Aug 20, 2008, at 10:02 AM, Mi Yan wrote:

> I have one MPI job consisting of two parts. One is "foo_x86", the  
> other is "foo_ppc", and there is MPI communication between "foo_x86"  
> and "foo_ppc".
> "foo_x86" is built on X86 box "b1", "foo_pcc" is built on PPC box  
> "b2". Anyone can tell me how to start this MPI job?
>
> I tried "mpirun -np 1 foo_x86 : -np 1 foo_ppc -H b1,b2"
>
> I tried the above command on "b1", the X86 box, and I got "foo_ppc:  
> Exec Format error"
> I tired on "b2", the PPC box, and I got "foo_x86: Exec format error"
>
> Anybody has a clue? Thanks in advance.
>
> Mi Yan
>
> _______________________________________________
> users mailing list
> users@open-mpi.org
>
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users