Hi:
May be you do not have 12 entries in your machine.list file. You need to have atleast np lines in your machine.list

Dr. Swamy N. Kandadai
IBM Senior Certified Executive IT Specialist
STG WW Modular Systems Benchmark Center
STG WW HPC and BI CoC Benchmark Center
Phone:( 845) 433 -8429 (8-293) Fax:(845)432-9789
swamy@us.ibm.com
http://w3.ibm.com/sales/systems/benchmarks





Inactive hide details for "Aditya Vasal" <Aditya.Vasal@kpitcummins.com>"Aditya Vasal" <Aditya.Vasal@kpitcummins.com>


          "Aditya Vasal" <Aditya.Vasal@kpitcummins.com>
          Sent by: users-bounces@open-mpi.org

          07/02/2008 07:36 AM
          Please respond to
          Open MPI Users <users@open-mpi.org>


To

<users@open-mpi.org>

cc


Subject

[OMPI users] Need some help regarding Linpack execution

Hi,

I want to perform LINPACK test on my m/c, I have only 1 GB RAM on the m/c where I want to run 12 parallel Linpack processes on SLES 10.
I am using of Mpich-1.2.7p1. (Mpich is built with –rsh=ssh option)
I have modified HPL.dat accordingly,
P = 3
Q = 4 (so as to make PxQ = 12)
N = 8640 (so as to make use of only 56% of available memory and leave rest for host processes)
NB = 11520
I have also set ulimit –l unlimited..
Created a machine.list file by specifying my m/c’s IP address 12 times. (So as to execute all 12 processes on the same m/c) and using GotoBLAS for the Linpack execution

Execution command:
mpirun –np 12 –machinefile machine.list xhpl

Upon execution, I get following error:

HPL ERROR from process # 0, on line 419 of function HPL_pdinfo:
>>> Need at least 12 processes for these tests <<<

Please guide me where am I going wrong


Best Regards,
Aditya Vasal

Software Engg | Semiconductor Solutions Group |KPIT Cummins Infosystems Ltd. | +91 99 70 168 581 |Aditya.Vasal@kpitcummins.com |www.kpitcummins.com
_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users