Dear Sir:
 
I am trying to install Open MPI on a cluster that has been installed with mpich-
gm  MPI.
 
I have followed the steps on your website.
I can compile and run the Hello_c application correctly.
 
But, how can I make sure that the application is run by Open MPI not by mpich-
gm MPI ?
 
I have changed PATH and LD_LIBRARY_PATH:
 
I deleted /opt/mpich-gm/bin from PATH and added
/ptmp/myname/openmpi123/ompi123_install/bin/ into PATH.
 
LD_LIBRARY_PATH=/ptmp/myname/openmpi123/ompi123_install/lib
 
And then, I got
 
-bash-3.00$ which mpirun
/ptmp/myname/openmpi123/ompi123_install/bin/mpirun
 
In my job script , I used
 
"time mpirun -np 16  /ptmp/jxding/openmpi123/openmpi-1.2.3/examples/hello_c"

Then I added "which mpirun" in my job script, and then submited my job to the
cluster , I got :
====================================
/opt/mpich-gm/bin/mpirun
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
Hello, world, I am 0 of 1
0.117u 0.165s 0:09.54 2.8%      0+0k 0+0io 0pf+0w
====================================
So , it means that the application is still using MPICH-GM not Open MPI.
Would you please help me with that ?

thanks,
 
Tony
 
June 16  2008

Now you can invite friends from Facebook and other groups to join you on Windows Live™ Messenger. Add them now!