Here are the details of my env. My machine has only one ethernet network adapter. If anything is missed, please let me know.


[root@xblade08 wwh]# uname -a
Linux xblade08.clusters.com 2.6.18-87.el5 #1 SMP Tue Mar 25 17:28:02 EDT 2008 i686 i686 i386 GNU/Linux
[root@xblade08 wwh]# cat /etc/*release
Red Hat Enterprise Linux Server release 5.2 Beta (Tikanga)
[root@xblade08 wwh]# echo $PATH
/opt/intel/fc/10.1.015/bin:/opt/intel/cc/10.1.015/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/opt/bin:/opt/xcat/bin:/opt/xcat/sbin:/opt/intel/cc/10.1.015/bin:/opt/intel/fc/10.1.015/bin:/root/bin
[root@xblade08 wwh]# echo $LD_LIBRARY_PATH
/opt/intel/fc/10.1.015/lib:/opt/intel/cc/10.1.015/lib
[root@xblade08 wwh]# rpm -qa|grep intel
intel-ifort101015-10.1.015-1
intel-isubh101015-10.1.015-1
intel-iidb101015-10.1.015-1
intel-icc101015-10.1.015-1
[root@xblade08 wwh]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0D:60:9C:09:CA
inet addr:172.20.3.24 Bcast:172.20.255.255 Mask:255.255.0.0
inet6 addr: fe80::20d:60ff:fe9c:9ca/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1030390 errors:0 dropped:0 overruns:0 frame:0
TX packets:422275 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:78898265 (75.2 MiB) TX bytes:155746699 (148.5 MiB)
Interrupt:169

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2154 errors:0 dropped:0 overruns:0 frame:0
TX packets:2154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:177404 (173.2 KiB) TX bytes:177404 (173.2 KiB)

I run "./configure CC=icc CXX=icpc FC=ifort F77=ifort" and "make all install" to install open mpi. The config.log can be got in the attched tarball. After these two command, mpic* commands seem to work.
[root@xblade08 wwh]# mpicc --showme
icc -I/usr/local/include -pthread -L/usr/local/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil
[root@xblade08 wwh]# mpif77 --showme
ifort -I/usr/local/include -pthread -L/usr/local/lib -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil

Then I used open mpi to compile lamtests 7.1.4, downloaded from http://www.lam-mpi.org/7.1/test-suite.php. "./configure CC=icc CXX=icpc FC=ifort F77=ifort" failed with following message:
[root@xblade08 lamtests-7.1.4]# ./configure CC=icc CXX=icpc FC=ifort F77=ifort
Configuring LAM test suite version 7.1.4
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for mpicc... yes
checking for gcc... mpicc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
[root@xblade08 lamtests-7.1.4]# grep cannot config.log
./a.out: error while loading shared libraries: libopen-rte.so.0: cannot open shared object file: No such file or directory
configure:2388: error: cannot run C compiled programs.
[root@xblade08 lamtests-7.1.4]# file /usr/local/lib/libopen-rte.so.0
/usr/local/lib/libopen-rte.so.0: symbolic link to `libopen-rte.so.0.0.0'

(See attached file: mpilibs.tar.gz)

Wen Hao Wang

Inactive hide details for Jeff Squyres <jsquyres@cisco.com>Jeff Squyres <jsquyres@cisco.com>


          Jeff Squyres <jsquyres@cisco.com>
          Sent by: users-bounces@open-mpi.org

          2008-05-16 22:35
          Please respond to
          Open MPI Users <users@open-mpi.org>


To

Open MPI Users <users@open-mpi.org>

cc


Subject

Re: [OMPI users] Compiler Choice in openmpi

On May 15, 2008, at 12:58 PM, Wen Hao Wang wrote:

> After I run "./configure CC=icc CXX=icpc FC=ifort F77=ifort" and  
> "make all install", some libs are installed to /usr/local/lib. These  
> libs can not be found when compiling my program, how should I do?
>

Can you send all the information listed here:

   
http://www.open-mpi.org/community/help/

And also the output you're seeing when your application fails to  
compile.

Thanks!

--
Jeff Squyres
Cisco Systems

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users