Hi,

I use sometimes OpenMPI and it looks like the mpicc wrapper gives gcc an inexistant directory with -I option. If I ask mpicc how it calls gcc it prints the following:

   [audet@linux15 libdfem]$ mpicc -show
   gcc -I/usr/local/openmpi-1.1.2/include -I/usr/local/openmpi-1.1.2/include/openmpi -pthread -L/usr/local/openmpi-1.1.2/lib -lmpi -lorte -lopal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
   [audet@linux15 libdfem]$ ls /usr/local/openmpi-1.1.2/include /usr/local/openmpi-1.1.2/include/openmpi
   ls: /usr/local/openmpi-1.1.2/include/openmpi: No such file or directory
   /usr/local/openmpi-1.1.2/include:
   mpi.h  mpif-common.h  mpif-config.h  mpif.h
   [audet@linux15 libdfem]$                              

The directory 'usr/local/openmpi-1.1.2/include/openmpi' doesn't exist. And this explains the annoying warnings I get when I compile my sources (I like to have no warning):

   cc1plus: warning: /usr/local/openmpi-1.1.2/include/openmpi: No such file or directory

This happens with OpenMPI 1.1.2 configured as follow:

   ./configure --prefix=/usr/local/openmpi-1.1.2 --disable-mpi-f90 --disable-mpi-cxx --disable-cxx-exceptions   --with-io-romio-flags=--with-file-system=ufs+nfs

Thanks,

Martin Audet