Michael,

I just did a quick config of 1.1.2 using PGI 6.2-4 and didn't run into this problem.

Here's the environment I used (similar to yours):

CXX=/usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgCC
F90=/usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgf90
PGI=/usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4
FC=/usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgf95
F77=/usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgf77
CC=/usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgcc
F90FLAGS=-fastsse
CXXFLAGS=-g -O3 -Minfo=all  -fastsse -Mipa=fast -Knoieee -mp
FCFLAGS=-fastsse
CFLAGS=-g -O3 -Minfo=all  -fastsse -Mipa=fast -Knoieee -mp
FFLAGS=-fastsse

Here's my configure options:

/configure --prefix=/usr/projects/hpctools/packages/x86_64/OpenMPI/openmpi-1.1.2 --with-io_romio_flags=--disable-aio --with-bproc


*** Fortran 77 compiler
checking whether we are using the GNU Fortran 77 compiler... no
checking whether /usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgf77 accepts -g... yes
checking if Fortran 77 compiler works... yes
checking /usr/projects/hpctools/packages/x86_64/PGI/pgi_6.2-4/linux86-64/6.2/bin/pgf77 external symbol convention... sin
gle underscore
checking if Fortran 77 compiler supports LOGICAL... yes
checking size of Fortran 77 LOGICAL... 4
checking for C type corresponding to LOGICAL... int
checking alignment of Fortran LOGICAL... 4
...

-david
--
David Gunter
HPC-4: HPC Environments: Parallel Tools Team
Los Alamos National Laboratory


On Dec 14, 2006, at 12:01 PM, Michael Galloway wrote:

good day all, i've been trying to build ompi with the 6.2-X version of the pgi
compiler set (pgcc 6.2-4 64-bit target on x86-64 Linux). i've tried both 1.1.2 and
the current nightly build 1.1.3b2r12766, both fail with this error from configure:

*** Fortran 77 compiler
checking whether we are using the GNU Fortran 77 compiler... no
checking whether /opt/pgi/linux86-64/6.2/bin/pgf77 accepts -g... yes
checking if Fortran 77 compiler works... yes
checking /opt/pgi/linux86-64/6.2/bin/pgf77 external symbol convention... single underscore
checking if Fortran 77 compiler supports LOGICAL... yes
checking size of Fortran 77 LOGICAL... 4
checking for C type corresponding to LOGICAL... not found
configure: WARNING: *** Did not find corresponding C type
configure: error: Cannot continue

i will attache the config.log file. i've looked around the maillist and i've seen a few issue
similar but no real resolution. the env i used to build is:

F90=/opt/pgi/linux86-64/6.2/bin/pgf90
F77=/opt/pgi/linux86-64/6.2/bin/pgf77
LM_LICENSE_FILE=/opt/pgi/license.dat
CXX=/opt/pgi/linux86-64/6.2/bin/pgCC
FC=/opt/pgi/linux86-64/6.2/bin/pgf90
CC=/opt/pgi/linux86-64/6.2/bin/pgcc

F90FLAGS=-fastsse
CXXFLAGS=-g -O3 -Minfo=all  -fastsse -Mipa=fast -Knoieee -mp
FCFLAGS=-fastsse
CFLAGS=-g -O3 -Minfo=all  -fastsse -Mipa=fast -Knoieee -mp
FFLAGS=-fastsse

is there something simple i'm messing up? thanks!

-- michael
<config.log>
_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users