Yes, it seems to begin to run with firewall off (gui), initiates the number of called mpirun processes, then terminates with no errors.

On 1/24/2014 7:48 PM, Ralph Castain wrote:
Have you tried just turning the firewall "off"? It would at least let you know if things work.

On Jan 24, 2014, at 3:48 PM, Dan Hsu <dkhsu@ucdavis.edu> wrote:

Ralph, thanks. I checked, and 'remote login' has been on.

It's frustrating, like pulling-out-hair time.


On 1/24/2014 1:11 PM, Ralph Castain wrote:
The procs attempt to open a socket back to mpirun for communication, so the firewall has to allow TCP communication. I usually turn on the "remote login" feature in the "sharing" area in preferences.


On Jan 23, 2014, at 4:34 PM, Dan Hsu <dkhsu@ucdavis.edu> wrote:

Hi All

Am trying to run a parallel molecular simulation from the directory containing the executable (using only available cores on the local cpus) on Mac Lion and keep getting an apparent firewall error that cannot be resolved. I am entering:

mpirun  -np 2 -e ./mpierr1 dock6.mpi -otherinput

and get transient (too quick to Allow) notification messages 'Do you want the application "orterun" to accept incoming network connections? Clicking Deny may limit....... The setting can be changed in the firewall pane......."

The mpirun message says:
--------------
Initializing MPI Routines...
Initializing MPI Routines...

--------------

I can specify orterun as a trusted app with "sudo /usr/libexec/ApplicationFirewall/socketfilterfw -t /usr/local/bin/orterun". Before, and after allowing firewall access by orterun and dock6.mpi I get the following by viewing the /var/log/appfirewall.log:

Jan 24 00:48:45 Dans-Mac Firewall[23513]: orterun is listening from 0.0.0.0:50722 proto=6
Jan 24 00:48:45 Dans-Mac Firewall[23513]: dock6.mpi is listening from 0.0.0.0:50723 proto=6
Jan 24 00:48:45 Dans-Mac Firewall[23513]: dock6.mpi is listening from 0.0.0.0:50724 proto=6
Jan 24 00:48:45 Dans-Mac Firewall[23513]: dock6.mpi is listening from 0.0.0.0:1024 proto=6
Jan 24 00:48:45 Dans-Mac Firewall[23513]: dock6.mpi is listening from 0.0.0.0:1025 proto=6

It appears that something is trying to start but cannot, and I dont know what else to try. Can anyone suggest how this might be resolved?

Thanks much for any input!
Dan


_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users



_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users



_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users