Hi All,

I have a problem to add a MPI library libmpi_cxx.so.1 to code which I am workign on it, I export the library to LD_LIBRARY_PATH. But whenever I do this, I get this error:
Fatal error in MPI_Comm_dup: Invalid communicator, error stack:
MPI_Comm_dup(168): MPI_Comm_dup(comm=0x0, new_comm=0x7fff39826eac) failed
MPI_Comm_dup(96).: Invalid communicator

It might be possible that I have several openmpi in my linux machine and the code could not recognize right one. I just have this library in these two path: /usr/lib64/openmpi/lib/ and /usr/local/lib/, but none of them is not working in my case. Installed openmpi in my machine is openmpi-1.5.4-3.fc16.x86_64 and I am working with Fedora.
Does anybody can help me to figure out this problem?

Thanks,
Ami