What version of OMPI are you using?
Latest, stable: 1.6.4.