Hi Chuck, 

No, I tried the examples but they did not work as well. Hope the issues would be resolved soon.

Regards,
Karos

On 18 Jan 2013, at 20:26, Ralph Castain <rhc@open-mpi.org> wrote:

I expect it to be in the 1.7.1 release - we just need some time to really test it and clean things up.

Meantime, it is available in the developer's nightly tarball, or via svn checkout.


On Jan 18, 2013, at 12:23 PM, Chuck Mosher <chuckmosher@yahoo.com> wrote:

Ralph - I'm relying on you guys to support Java, hope it makes it back in soon !!!

I've had no problems, by the way.

Karos - Were you able to make and run the Java examples in the MPI_ROOT/examples directory ?

I started with those after similar hiccups trying to get things up and running.

Chuck Mosher


From: Ralph Castain <rhc@open-mpi.org>
To: Open MPI Users <users@open-mpi.org>
Sent: Thursday, January 17, 2013 2:27 PM
Subject: Re: [OMPI users] Problem with mpirun for java codes

Just as an FYI: we have removed the Java bindings from the 1.7.0 release due to all the reported errors - looks like that code just isn't ready yet for release. It remains available on the nightly snapshots of the developer's trunk while we continue to debug it.

With that said, I tried your example using the current developer's trunk - and it worked just fine.

I ran it on a single node, however. Were you running this across multiple nodes? Is it possible that the "classes" directory wasn't available on the remote node?


On Jan 16, 2013, at 4:17 PM, Karos Lotfifar <foadfbf@gmail.com> wrote:

Hi, 
The version that I am using is 

1.7rc6 (pre-release)


Regards,
Karos

On 16 Jan 2013, at 21:07, Ralph Castain <rhc@open-mpi.org> wrote:

Which version of OMPI are you using?


On Jan 16, 2013, at 11:43 AM, Karos Lotfifar <foadfbf@gmail.com> wrote:

Hi,

I am still struggling with the installation problems! I get very strange errors. everything is fine when I run OpenMPI for C codes, but when I try to run a simple java code I get very strange error. The code is as simple as the following and I can not get it running:

import mpi.*;

class JavaMPI {
  public static void main(String[] args) throws MPIException {
    MPI.Init(args);
    System.out.println("Hello world from rank " +
      MPI.COMM_WORLD.Rank() + " of " +
      MPI.COMM_WORLD.Size() );
    MPI.Finalize();
  }
}

everything is ok with mpijavac, my java code, etc. when I try to run the code with the following command:

/usr/local/bin/mpijavac -d classes JavaMPI.java       --> FINE
/usr/local/bin/mpirun -np 2 java -cp ./classes JavaMPI  --> *ERROR*

I'll the following error. Could you please help me about this (As I mentioned the I can run C MPI codes without any problem ). The system specifications are:

JRE version: 6.0_30-b12 (java-sun-6)
OS: Linux 3.0.0-30-generic-pae #47-Ubuntu
CPU:total 4 (2 cores per cpu, 2 threads per core) family 6 model 42 stepping 7, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, ht




##################################################################################################################
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x70e1dd12, pid=28616, tid=3063311216
#
 (0xb) at pc=0x70f61d12, pid=28615, tid=3063343984
#
# JRE version: 6.0_30-b12
# JRE version: 6.0_30-b12
# Java VM: Java HotSpot(TM) Server VM (20.5-b03 mixed mode linux-x86 )
# Problematic frame:
# C  [libmpi.so.1+0x20d12]  unsigned __int128+0xa2
#
# An error report file with more information is saved as:
# /home/karos/hs_err_pid28616.log
# Java VM: Java HotSpot(TM) Server VM (20.5-b03 mixed mode linux-x86 )
# Problematic frame:
# C  [libmpi.so.1+0x20d12]  unsigned __int128+0xa2
#
# An error report file with more information is saved as:
# /home/karos/hs_err_pid28615.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
[tulips:28616] *** Process received signal ***
[tulips:28616] Signal: Aborted (6)
[tulips:28616] Signal code:  (-6)
[tulips:28616] [ 0] [0xb777840c]
[tulips:28616] [ 1] [0xb7778424]
[tulips:28616] [ 2] /lib/i386-linux-gnu/libc.so.6(gsignal+0x4f) [0xb75e3cff]
[tulips:28616] [ 3] /lib/i386-linux-gnu/libc.so.6(abort+0x175) [0xb75e7325]
[tulips:28616] [ 4] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(+0x5dcf7f) [0xb6f6df7f]
[tulips:28616] [ 5] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(+0x724897) [0xb70b5897]
[tulips:28616] [ 6] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(JVM_handle_linux_signal+0x21c) [0xb6f7529c]
[tulips:28616] [ 7] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(+0x5dff64) [0xb6f70f64]
[tulips:28616] [ 8] [0xb777840c]
[tulips:28616] [ 9] [0xb3891548]
[tulips:28616] *** End of error message ***
[tulips:28615] *** Process received signal ***
[tulips:28615] Signal: Aborted (6)
[tulips:28615] Signal code:  (-6)
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
[tulips:28615] [ 0] [0xb778040c]
[tulips:28615] [ 1] [0xb7780424]
[tulips:28615] [ 2] /lib/i386-linux-gnu/libc.so.6(gsignal+0x4f) [0xb75ebcff]
[tulips:28615] [ 3] /lib/i386-linux-gnu/libc.so.6(abort+0x175) [0xb75ef325]
[tulips:28615] [ 4] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(+0x5dcf7f) [0xb6f75f7f]
[tulips:28615] [ 5] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(+0x724897) [0xb70bd897]
[tulips:28615] [ 6] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(JVM_handle_linux_signal+0x21c) [0xb6f7d29c]
[tulips:28615] [ 7] /usr/lib/jvm/java-6-sun-1.6.0.30/jre/lib/i386/server/libjvm.so(+0x5dff64) [0xb6f78f64]
[tulips:28615] [ 8] [0xb778040c]
[tulips:28615] [ 9] [0xb3899548]
[tulips:28615] *** End of error message ***
--------------------------------------------------------------------------
mpirun noticed that process rank 1 with PID 28616 on node tulips exited on signal 6 (Aborted).
--------------------------------------------------------------------------

##################################################################################################################

--
Regards,
Karos Lotfifar _______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users
_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users


_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users