I tried building the latest OpenMPI-1.6.3 with MXM support and got this error:

 

make[2]: Entering directory `Src/openmpi-1.6.3/ompi/mca/mtl/mxm'

  CC     mtl_mxm.lo

  CC     mtl_mxm_cancel.lo

  CC     mtl_mxm_component.lo

  CC     mtl_mxm_endpoint.lo

  CC     mtl_mxm_probe.lo

  CC     mtl_mxm_recv.lo

  CC     mtl_mxm_send.lo

mtl_mxm_send.c: In function 'ompi_mtl_mxm_send':

mtl_mxm_send.c:96: error: 'mxm_wait_t' undeclared (first use in this function)

mtl_mxm_send.c:96: error: (Each undeclared identifier is reported only once

mtl_mxm_send.c:96: error: for each function it appears in.)

mtl_mxm_send.c:96: error: expected ';' before 'wait'

mtl_mxm_send.c:104: error: 'MXM_REQ_FLAG_BLOCKING' undeclared (first use in this function)

mtl_mxm_send.c:118: error: 'MXM_REQ_FLAG_SEND_SYNC' undeclared (first use in this function)

mtl_mxm_send.c:134: error: 'wait' undeclared (first use in this function)

mtl_mxm_send.c: In function 'ompi_mtl_mxm_isend':

mtl_mxm_send.c:183: error: 'MXM_REQ_FLAG_SEND_SYNC' undeclared (first use in this function)

make[2]: *** [mtl_mxm_send.lo] Error 1

 

 

Our OFED is 1.5.3 and our MXM version is 1.0.601.

 

Thanks,

 

-Jeff

 

/**********************************************************/

/* Jeff Konz                          jeffrey.konz@hp.com */

/* Solutions Architect                   HPC Benchmarking */

/* Americas Shared Solutions Architecture (SSA)           */

/* Hewlett-Packard Company                                */

/* Office: 248-491-7480              Mobile: 248-345-6857 */

/**********************************************************/