The reason is that you aren't actually running Open MPI - those error messages are coming from MPICH. Check your path and ensure you put the OMPI install location first, or use the absolute path to the OMPI mpirun

On Oct 27, 2012, at 8:46 AM, Giuseppe P. <istruzione@gmail.com> wrote:

Hello!

I have built open mpi 1.6 with Intel compilers (2013 versions). Compilation was smooth, however even when I try to execute
the simple program hello.c:

mpirun -np 4 ./hello_c.x
[mpiexec@claudio.ukzn] HYDU_create_process (./utils/launch/launch.c:102): execvp error on file /opt/intel/composer_xe_2013.0.079/mpirt/bin/intel64/pmi_proxy (No such file or directory)
[mpiexec@claudio.ukzn] HYD_pmcd_pmiserv_proxy_init_cb (./pm/pmiserv/pmiserv_cb.c:1177): assert (!closed) failed
[mpiexec@claudio.ukzn] HYDT_dmxu_poll_wait_for_event (./tools/demux/demux_poll.c:77): callback returned error status
[mpiexec@claudio.ukzn] HYD_pmci_wait_for_completion (./pm/pmiserv/pmiserv_pmci.c:358): error waiting for event
[mpiexec@claudio.ukzn] main (./ui/mpich/mpiexec.c:689): process manager error waiting for completion

Before that, there was an additional error, since also the file mpivars.sh was not present in /opt/intel/composer_xe_2013.0.079/mpirt/bin/intel64/.
Even though I managed to create one and it worked:

#!/bin/bash

if [ -z "`echo $PATH | grep /usr/local/bin`" ]; then
export PATH=/usr/local/bin:$PATH
fi

if [ -z "`echo $LD_LIBRARY_PATH | grep /usr/local/lib`" ]; then
if [ -n "$LD_LIBRARY_PATH" ]; then
export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
else
export LD_LIBRARY_PATH=/usr/local/lib
fi
fi

I do not have any clue about how to generate the file pmi_proxy.

Thank you in advance for your help!

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users