You forgot to call MPI_Init at the beginning of your program.

On Sep 25, 2012, at 2:08 PM, Mariana Vargas Magana <mmarianav@yahoo.com.mx> wrote:

Hi
I think I'am not understanding what you said , here is the hello.py and next the command mpirun…

Thanks!

#!/usr/bin/env python
"""
Parallel Hello World
"""

from mpi4py import MPI
import sys

size = MPI.COMM_WORLD.Get_size()
rank = MPI.COMM_WORLD.Get_rank()
name = MPI.Get_processor_name()

sys.stdout.write(
    "Hello, World! I am process %d of %d on %s.\n"
    % (rank, size, name))

 ~/bin/mpirun -np 70 python2.7 helloworld.py 
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.
Hello, World! I am process 0 of 1 on ferrari.

On Sep 25, 2012, at 4:46 PM, Ralph Castain <rhc@open-mpi.org> wrote:

The usual reason for this is that you aren't launching these processes correctly. How are you starting your job? Are you using mpirun?


On Sep 25, 2012, at 1:43 PM, mariana Vargas <mmarianav@yahoo.com.mx> wrote:

Hi

I fact I found what is the origin of this problem and it is because all processes have rank 0, so I tested and in effect even when I send the clasical Hello.py give the same, how can I solved this?? Do I  re installed every again???

Help please...

Mariana



On Sep 24, 2012, at 9:13 PM, Mariana Vargas Magana wrote:



Yes you are right this is what it says but if fact the weird thing is that not all times the error message appears….I send to 20 nodes and only one gives this message, is this normal…




On Sep 24, 2012, at 8:00 PM, Ralph Castain <rhc@open-mpi.org> wrote:

Well, as it says, your processes called MPI_Init, but at least one of them exited without calling MPI_Finalize. That violates the MPI rules and we therefore terminate the remaining processes.

Check your code and see how/why you are doing that - you probably have a code path whereby a process exits without calling finalize.


On Sep 24, 2012, at 4:37 PM, mariana Vargas <mmarianav@yahoo.com.mx> wrote:




Hi all

I get this error when I run a paralelized python code in a cluster, could anyone give me an idea of what is happening? I'am new in this Thanks...

mpirun has exited due to process rank 2 with PID 10259 on
node f01 exiting improperly. There are two reasons this could occur:

1. this process did not call "init" before exiting, but others in
the job did. This can cause a job to hang indefinitely while it waits
for all processes to call "init". By rule, if one process calls "init",
then ALL processes must call "init" prior to termination.

2. this process called "init", but exited without calling "finalize".
By rule, all processes that call "init" MUST call "finalize" prior to
exiting or it will be considered an "abnormal termination"

This may have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).

Thanks!!




Dr. Mariana Vargas Magana
Astroparticule et Cosmologie - Bureau 409B
PHD student- Université Denis Diderot-Paris 7
10, rue Alice Domon et Léonie Duquet
75205 Paris Cedex - France
Tel. +33 (0)1 57 27 70 32
Fax. +33 (0)1 57 27 60 71
mariana@apc.univ-paris7.fr

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users