Hi Dmitry:

Let me look into this.




From: users-bounces@open-mpi.org [mailto:users-bounces@open-mpi.org] On Behalf Of Dmitry N. Mikushin
Sent: Monday, June 18, 2012 10:56 AM
To: Open MPI Users
Subject: Re: [OMPI users] NVCC mpi.h: error: attribute "__deprecated__" does not take arguments


Yeah, definitely. Thank you, Jeff.

- D.

2012/6/18 Jeff Squyres <jsquyres@cisco.com>

On Jun 18, 2012, at 10:41 AM, Dmitry N. Mikushin wrote:

> No, I'm configuring with gcc, and for openmpi-1.6 it works with nvcc without a problem.

Then I think Rolf (from Nvidia) should figure this out; I don't have access to nvcc.  :-)

> Actually, nvcc always meant to be more or less compatible with gcc, as far as I know. I'm guessing in case of trunk nvcc is the source of the issue.
> And with ./configure CC=nvcc ....etc. it won't build:
> /home/dmikushin/forge/openmpi-trunk/opal/mca/event/libevent2019/libevent/include/event2/util.h:126:2: error: #error "No way to define ev_uint64_t"

You should complain to Nvidia about that.

Jeff Squyres
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/

users mailing list


This email message is for the sole use of the intended recipient(s) and may contain confidential information.  Any unauthorized review, use, disclosure or distribution is prohibited.  If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message.