Hello,

I have built openmpi-1.6 for MacOSX Lion 10.7.4 with intel compilers v12.1 (icc,icpc,ifort)

When I try to install the mpif90 wrapper, I have the error message : ifort: error #10104: unable to open '-commons'

When I compare "mpif90 -showme" from version 1.5.4 and version 1.6, I find :


/opt/openmpi-1.5.4/bin/mpif90 -showme
/opt/intel/composerxe/bin/ifort -I/opt/openmpi-1.5.4/include -I/opt/openmpi-1.5.4/lib -L/opt/openmpi-1.5.4-v12/lib -lmpi_f90 -lmpi_f77 -lmpi

/opt/openmpi-1.6/bin/mpif90 -showme
/opt/intel/composerxe/bin/ifort -I/opt/openmpi-1.6/include -Wl,-commons,use_dylibs -I/opt/openmpi-1.6/lib -L/opt/openmpi-1.6/lib -lmpi_f90 -lmpi_f77 -lmpi -lm

What are options -Wl,-commons,use_dylibs ? Can I remove it and How ?

--
Christophe Peyret
ONERA - DSNA - PS3A