Can you clarify your answer please.
I have one master node and other slave nodes. I created rsa key on my master node and copied it to all slaves.
/home/mpiuser directory of all nodes are shared through NFS.The strange thing is why it requires password after I mount a slave and do ssh to the slave.
When I dismount I can ssh without password.

 

Date: Tue, 20 Dec 2011 10:45:12 +0100
From: mathieu.westphal@obs.ujf-grenoble.fr
To: users@open-mpi.org
Subject: Re: [OMPI users] Passwordless ssh

Hello

You have to copy nodeX public key at the end of nodeY authorizedkeys.


Mathieu
Le 20/12/2011 05:03, Shaandar Nyamtulga a écrit :
Hi
I built Beuwolf cluster using OpenMPI reading the following link.
http://techtinkering.com/2009/12/02/setting-up-a-beowulf-cluster-using-open-mpi-on-linux/
I can access my nodes without password before mounting my slaves.
But when I mount my slaves and run a program, it asks again passwords.
$ eval `ssh-agent`
$ ssh-add ~/.ssh/id_dsa

The above is not working. Terminal gives the reply "Could not open a connection to your authentication agent."

Help is needed urgently.

Thank you




_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users


_______________________________________________ users mailing list users@open-mpi.org http://www.open-mpi.org/mailman/listinfo.cgi/users