hello all :
 
       I  installed  the openmpi-1.4.3  on redhat as the following step :
 
       1.  ./configure  --prefix=/data1/cluster/openmpi
 
       2.  make
 
       3.  make  install
 
       And  I   compiled  the  examples  of  openmpi-1.4.3  as the following step :
 
       1. make
 
        Then  I   run   the example : 
 
            ./mpirun  -np 1  /tmp/openmpi-1.4.3/examples/ring_c 
 
        I  get  the following  error :
 
-----------------------------------------------------------------------------
It seems that there is no lamd running on the host node1.
This indicates that the LAM/MPI runtime environment is not operating.
The LAM/MPI runtime environment is necessary for MPI programs to run
(the MPI program tired to invoke the "MPI_Init" function).
 
Please run the "lamboot" command the start the LAM/MPI runtime
environment.  See the LAM/MPI documentation for how to invoke
"lamboot" across multiple machines.
-----------------------------------------------------------------------------
     
       I   run openmpi , but  I  get  the error from lam-mpi .  why ?      Can  you  help me ?
 
       Thank you !