We don't directly link to that library, so it must be getting pulled in by some other lib. Have you tried adding /usr/heimdal/lib to your LD_LIBRARY_PATH before building?


On Jul 6, 2011, at 3:27 AM, Sushil Mishra wrote:

Hi all:
I am trying to install openmpi-1.5.2 in Debian 4.3.2-1.1. I am not a root user and I have to do it as user. The problem I am facing is in "make all" and error is fallowing:


Making all in mca/plm/tm
make[2]: Entering directory `/home/sushil/Softwares/amber11/AmberTools/src/openmpi-1.5.2/orte/mca/plm/tm'
  CC     plm_tm_component.lo
  CC     plm_tm_module.lo
  CCLD   mca_plm_tm.la
/bin/grep: /usr/lib/libgssapi.la: No such file or directory
/bin/sed: can't read /usr/lib/libgssapi.la: No such file or directory
libtool: link: `/usr/lib/libgssapi.la' is not a valid libtool archive
make[2]: *** [mca_plm_tm.la] Error 1
make[2]: Leaving directory `/home/sushil/Softwares/amber11/AmberTools/src/openmpi-1.5.2/orte/mca/plm/tm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sushil/Softwares/amber11/AmberTools/src/openmpi-1.5.2/orte'
make: *** [all-recursive] Error 1

It cant find libgssapi.la file in /usr/lib whereas this file is present in /usr/heimdal/lib/ not in /usr/lib/  . I cant see where to change the path so that it can use it from there, or really I am missing some other packages ? Can any of you please suggest me how to tell this path to the script?

Sincerely
Sushil

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users