That last error is because you don't have permission to install to /opt as a regular user.  You need to run that command as  "sudo make install".

Damien

On 03/05/2011 1:55 PM, Steph Bredenhann wrote:
I think you are a genius!

The new result is attached, it was only the last step make install that
looked suspect.

I'll appreciate if you can look at these results?

While I am at it, thank you a million times for making this available to the
public! Without openmpi I would not have been able to complete my PhD!!!

Thanks

-----Original Message-----
From: users-bounces@open-mpi.org [mailto:users-bounces@open-mpi.org] On
Behalf Of Jeff Squyres
Sent: Tuesday, May 03, 2011 21:27
To: Open MPI Users
Subject: Re: [OMPI users] BUILDING OPENMPI ON UBUNTU WITH INTEL 11.1

Ah, I see why your output is munged -- there's a bunch of ^M's in there.

It looks like OMPI's configure script got mucked up somehow.  Did you expand
the tarball on a windows machine and copy it over to a Linux box, perchance?
If so, try expanding it directly on your Linux machine.



On May 3, 2011, at 2:15 PM, Steph Bredenhann wrote:

Thanks for the speedy reply. The required file with information is
attached.
I first thought I must send the file to openmpi again, sorry if that was
wrong.
Thanks


--
Steph Bredenhann Pr.Eng Pr.CPM


Quoting Jeff Squyres <jsquyres@cisco.com>:

Your output appears jumbled.  Can you send all the data listed here:

   http://www.open-mpi.org/community/help/

On May 3, 2011, at 1:36 PM, Steph Bredenhann wrote:

Dear Sir/Madam

I want to build openmpi for use with INTEL compilers (version 11.1) 
on my
Ubuntu
10.10 x64 system. I am using the guidelines from


        
http://software.intel.com/en-us/articles/performance-tools-for-softwar
e-developers-building-open-mpi-with-the-intel-compilers/
and specifically the following instructions:


./configure --prefix=/usr/local CC=icc CXX=icpc F77=ifort FC=ifort 
... output of configure ...
make all install
... output of build and installation ...

The result is shown below. As can be seen it was unsuccessful. I'll
appreciate
some guidance here as I am nearing the deadline for a project that 
is part
of
my research for my PhD.

Thanks in advance.

steph@sjb-linux:/src/openmpi-1.4.3$ ./configure 
--prefix=/opt/openmpi-1.4.3 CC=icc CXX=icpc F77=ifort FC=ifort 
checking for a BSD-compatible install... /usr/bin/install -c 
checking whether build environment is sane... yes
: command not foundconfig/missing: line 3:
: command not foundconfig/missing: line 5:
: command not foundconfig/missing: line 9:
: command not foundconfig/missing: line 14:
: command not foundconfig/missing: line 19:
: command not foundconfig/missing: line 24:
: command not foundconfig/missing: line 29:
/src/openmpi-1.4.3/config/missing: line 49: syntax error near 
unexpected
token
`'n
'src/openmpi-1.4.3/config/missing: line 49: `case $1 in
configure: WARNING: `missing' script is too old or missing checking 
for a thread-safe mkdir -p... /bin/mkdir -p checking for gawk... 
gawk checking whether make sets $(MAKE)... yes checking how to 
create a ustar tar archive... gnutar


=====================================================================
=======
== Configuring Open MPI

=====================================================================
=======
*** Checking versions
: integer expression expected 3
: integer expression expected 0
.4ecking Open MPI version... 1
checking Open MPI release date... Oct 05, 2010 checking Open MPI 
Subversion repository version... r23834
: integer expression expected 3
: integer expression expected 0
.4ecking Open Run-Time Environment version... 1 checking Open 
Run-Time Environment release date... Oct 05, 2010 checking Open 
Run-Time Environment Subversion repository version... r23834
: integer expression expected 3
: integer expression expected 0
.4ecking Open Portable Access Layer version... 1 checking Open 
Portable Access Layer release date... Oct 05, 2010 checking Open 
Portable Access Layer Subversion repository version... r23834
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found

*** Initialization, setup
configure: builddir: /src/openmpi-1.4.3
configure: srcdir: /src/openmpi-1.4.3
configure: error: cannot run /bin/sh config/config.sub 
steph@sjb-linux:/src/openmpi-1.4.3$ make all install
make: *** No rule to make target `all'.  Stop.
steph@sjb-linux:/src/openmpi-1.4.3$ make install
make: *** No rule to make target `install'.  Stop.
steph@sjb-linux:/src/openmpi-1.4.3$


Regards

Steph Bredenhann






--
This message was sent by Adept Internet's webmail.
http://www.adept.co.za/

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

--
Jeff Squyres
jsquyres@cisco.com
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/


_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

--
This message was sent by Adept Internet's webmail. 
http://www.adept.co.za/
<ompi-output.tar.bz2>_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________ users mailing list users@open-mpi.org http://www.open-mpi.org/mailman/listinfo.cgi/users