Setting the mca param plm_rsh_agent to "ssh -i xxx" should do the trick, I think - haven't tried it, but it should work.


On Feb 15, 2011, at 12:24 PM, Barnet Wagman wrote:


OMPI doesn't do anything relative to the .ssh directory, or what key is used for ssh authentication.

Afraid that is one you have to solve at the system level :-/
^ In that case, where and how does OMPI call ssh? 

ssh has a '-i' option which can be used to specify the id_rsa file.  If ssh is called in a script (or if there's a way to pass ssh args into OMPI), then I can just use that ssh option.

thanks
_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users