There have been many postings about openmpi-default-hostfile on the list, but I haven't found one that answers my question, so I hope you won't mind one more.

When I use mpirun, openmpi-default-hostfile does not appear to get used. I've added three lines to the default host file:
node0 slots=3
node1 slots=4
node2 slots=4
'node0' is the local (master) host.

If I explicitly list the hostfile in the mpirun command, everything works correctly.  E.g.
mpirun -np 15 -hostfile /full/path/to/openmpi-default-hostfile hello_c
works correctly - hello_c gets run using all three nodes.

However, if I don't specify the hostfile, only the local node, node0, is used. E.g.
mpirun -np 15 hello_c
creates all 15 processes on node0.  I was under the impression that all machines listed in openmpi-default-hostfile should get used by default.  Is that correct?

Unfortunately I can't use the hostfile command line option.  I'm going to be using a mpi app (npRmpi) that doesn't let me pass params to mpirun. So I need all my nodes used by default.

Configuration details:
openmpi 1.4.3, built from source.

OS: Debian lenny (but the Debian openmpi package is NOT installed).

Installation dir: /home/omu/openmpi

The default host file has pathname /home/omu/openmpi/etc/openmpi-default-hostfile

I've set two envirnmental variables to support open mpi:
PATH=/home/omu/openmpi/bin:...
LD_LIBRARY_PATH=/home/omu/openmpi/lib:...

Are there any other environmental variables that need to be set?

I'd appreciate any suggestions about this.

thanks,

Barnet Wagman