sunita@chem.iitb.ac.in wrote:
Dear Open-mpi users,

I installed openmpi-1.4.1 in my user area and then set the path for
openmpi in the .bashrc file as follow. However, am still getting following
error message whenever am starting the parallel molecular dynamics
simulation using GROMACS. So every time am starting the MD job, I need to
source the .bashrc file again.

Earlier in some other machine I did the same thing and was not getting any
problem.

Could you guys suggest what would be the problem?

  
Have you set OPAL_PREFIX to /home/sunitap/soft/openmpi?

If you do a ldd on mdrun_mpi does libmpi.so.0 come up not found?
If so and there truly is a libmpi.so.0 in /home/sunitap/soft/openmpi/lib
you may want to make sure the bitness of libmpi.so.0 and mdrun_mpi are the same by
doing a file command on both.

--td
============.bashrc============
#path for openmpi
export PATH=$PATH:/home/sunitap/soft/openmpi/bin
export CFLAGS="-I/home/sunitap/soft/openmpi/include"
export LDFLAGS="-L/home/sunitap/soft/openmpi/lib"
export LD_LIBRARY_PATH=/home/sunitap/soft/openmpi/lib:$LD_LIBRARY_PATH

============== error message ==============
mdrun_mpi: error while loading shared libraries: libmpi.so.0: cannot open
shared object file: No such file or directory

============================================

Thanks for any help.
Best regards,
Sunita

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users
  


--
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.650.633.7054
Oracle - Performance Technologies
95 Network Drive, Burlington, MA 01803
Email terry.dontje@oracle.com