Based on your questions from the LAM list, I think you are actually asking how to get support for MPI_THREAD_MULTIPLE (which will include pthread support on Linux systems).
Use the --enable-mpi-threads option to configure to enable support for MPI_THREAD_MULTIPLE (please see the README file for more details).  Per the warning from my previous mail (, this support is only partially implemented and tested.

From: [] On Behalf Of imran shaik
Sent: Friday, May 26, 2006 2:49 AM
To: openMPI mailing list
Subject: [OMPI users] Default configure options

I want to use phtreads with openmpi.
Does it configure with pthreads enabled by default or what options do i need to mention?


Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail Beta.