Does the "NODE 0: no room for lattice" message have any significance?  Could it be that for whatever reason the application is running out of memory?

--td

kishore kumar wrote:
Hi,
I am trying to run SPEC MPI 2007 workload on a quad-core machine. However getting this error message. I also tried to use hostfile option by specifying localhost slots=4, but still getting the following error. Please help me.

$mpirun  --mca btl tcp,sm,self -np 4 su3imp_base.solaris
SU3 with improved KS action
Microcanonical simulation with refreshing
MIMD version 6
Machine =
R algorithm
type 0 for no prompts  or 1 for prompts
nflavors 2
nx 30
ny 30
nz 56
nt 84
iseed 1234
LAYOUT = Hypercubes, options = EVENFIRST,
NODE 0: no room for lattice
termination: Tue Apr 27 23:41:44 2010

Termination: node 0, status = 1
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 0.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 17239 on
node cache-aware exiting without calling "finalize". This may
have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).


Best,
Kishore Kumar Pusukuri
http://www.cs.ucr.edu/~kishore


_______________________________________________ users mailing list users@open-mpi.org http://www.open-mpi.org/mailman/listinfo.cgi/users


--
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.650.633.7054
Oracle - Performance Technologies
95 Network Drive, Burlington, MA 01803
Email terry.dontje@oracle.com