OpenMPI version: 1.3.3

Platform: IBM P5

 

If I configure with just the --prefix option for where to install, and then run “make all install”, I get an “mpi.mod” file in the “lib” directory of the prefix directory I specified.  ALL GOOD!

 

When I add compiler options to the configure script (e.g. “CC=xlC_r CXX=xlC_r FC=xlf95_r”), I no longer get the “mpi.mod” file.

 

I have traced this to the Makefile in the “ompi/mpi/f90” directory.  When I add the compiler options to the configure script, a bunch of lines get commented out of the Makefile, including the ones that look like they build the “mpi.mod” file.

 

Can anyone tell me why this happens?

 

Thanks.