Jean Potsam wrote:
Dear All,
              I have installed openmpi 1.3.2 on one on the nodes of our cluster and is running a simple helloword mpi program. The program runs fine but I get a lot of unexpected messages in between the result.

##########################################

jean@n06:~/examples$ mpirun -np 2 --host n06 hello_c
libibverbs: Fatal: couldn't read uverbs ABI version.
--------------------------------------------------------------------------
[[11410,1],1]: A high-performance Open MPI point-to-point messaging module
was unable to find any relevant network interfaces:

Module: OpenFabrics (openib)
  Host: n06

Another transport will be used instead, although this may result in
lower performance.
--------------------------------------------------------------------------
libibverbs: Fatal: couldn't read uverbs ABI version.

Hello, world, I am 0 of 2 and running on n06
Hello, world, I am 1 of 2 and running on n06


[n06:08470] 1 more process has sent help message help-mpi-btl-base.txt / btl:no-nics
[n06:08470] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages

##########################

Does anyone know why these messages appear and how to fix this.

Thanks 

Jean

start: 0000-00-00 end: 0000-00-00

_______________________________________________ users mailing list users@open-mpi.org http://www.open-mpi.org/mailman/listinfo.cgi/users
You can define some default parameter in the $OMPIDIR/etc/openmpi-mca-params.conf

For instance, you can add :
# Exclude openib BTL, not currently supported
btl = ^openib,ofud

Yann

-- 
___________________________

Yann JOBIC
HPC engineer
Polytech Marseille DME
IUSTI-CNRS UMR 6595
Technopôle de Château Gombert
5 rue Enrico Fermi
13453 Marseille cedex 13
Tel : (33) 4 91 10 69 39
  ou  (33) 4 91 10 69 43
Fax : (33) 4 91 10 69 69