Hi Jody


What is the result of "which mpicc" (or whatever you are using for your compiling/linking?  I'm pretty sure that's where the library paths get set, and if you are calling /usr/bin/mpicc you will get the wrong library paths in the executable.  

Here you are:

$ which mpicc
/opt/openmpi/bin/mpicc

While:

$ otool -L solfec-mpi 
solfec-mpi:
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.4)
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib (compatibility version 1.0.0, current version 218.0.0)
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib (compatibility version 1.0.0, current version 218.0.0)
/System/Library/Frameworks/Python.framework/Versions/2.5/Python (compatibility version 2.5.0, current version 2.5.1)
/usr//lib/libmpi.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr//lib/libopen-rte.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr//lib/libopen-pal.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libutil.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

4. hand compilation with cc -L/opt/openmpi/lib -lmpi

Did 4 work?  

No, it didn't.

Thanks