I just tried this again (with the 1.0.2 version just released), but without explicitly setting any variables other than F77, and it worked.  The only problem with this approach is that I had previously set CC=gcc-3.3, etc., so that my mpicc would have gcc-3.3 even if that was not my default compiler.  If I build without setting these, I will now have to use gcc_select every time (and I will probably forget sometimes).


Thanks,
Charles


On Apr 10, 2006, at 2:12 PM, Warner Yuen wrote:

Hi Charles,

I've only ever seen that error when trying to build OpenMPI with the IBM XLC compilers on Tiger. I just now successfully configured and built OpenMPI-1.0.2 using gcc 3.3 build 1819 and IBM XLF.

./configure --disable-mpi-f90 --prefix=/hpc/mpis/ompi102f77

Please note that I can also build this with F90 support. As long as GCC 3.3 is used as my compiler. One curious thing is that if I set my envirornment to specifically use XLF, i.e. 'export F77=/opt/ibmcmp/xlf/8.1/bin/f77' it will fail in the configure step.

Just to be sure, OpenMPI fails to compile with your exact error if I first set my C compiler to IBM XLC.

Warner Yuen
Research Computing Consultant
Apple Computer
Tel: 408.718.2859
Fax: 408.715.0133


On Apr 10, 2006, at 9:00 AM, users-request@open-mpi.org wrote:

----------------------------------------------------------------------

Message: 1
Date: Mon, 10 Apr 2006 11:25:48 -0400
From: Charles Williams <willic3@rpi.edu>
Subject: [OMPI users] Building OpenMPI on OS X Tiger with gcc-3.3
Content-Type: text/plain; charset="us-ascii"

Hi,

I have been attempting to build OpenMPI on my Mac, using the older  
gcc-3.3 compiler using rc2r9567.  Things proceed for a while, and  
then I get:

Making all in xgrid
/Users/willic3/build/openmpi-buildgcc3.3/orte/dynamic-mca/pls/xgrid
depbase=`echo src/pls_xgrid_component.lo | sed 's|[^/]*$|.deps/&|;s| 
\.lo$||'`; \
if /bin/sh ../../../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I.  
-I/Users/willic3/build/openmpi-1.0.2rc2r9567/orte/mca/pls/xgrid - 
I../../../../include -I../../../../include  -I/Users/willic3/build/ 
openmpi-buildgcc3.3/include  -I/Users/willic3/build/ 
openmpi-1.0.2rc2r9567/include -I/Users/willic3/build/ 
openmpi-1.0.2rc2r9567 -I../../../.. -I../../../../include -I/Users/ 
willic3/build/openmpi-1.0.2rc2r9567/opal -I/Users/willic3/build/ 
openmpi-1.0.2rc2r9567/orte -I/Users/willic3/build/ 
openmpi-1.0.2rc2r9567/ompi  -D_REENTRANT -F XGridFoundation  -MT src/ 
pls_xgrid_component.lo -MD -MP -MF "$depbase.Tpo" -c -o src/ 
pls_xgrid_component.lo /Users/willic3/build/openmpi-1.0.2rc2r9567/ 
orte/mca/pls/xgrid/src/pls_xgrid_component.m; \
then mv -f "$depbase.Tpo" "$depbase.Plo"; else rm -f "$depbase.Tpo";  
exit 1; fi
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[4]: *** [src/pls_xgrid_component.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

I may be able to avoid this problem by building without xgrid (I'm  
going to try that now), but does anyone have any ideas on other  
solutions?  I've built the code successfully using the default Tiger  
compilers.

Thanks,
Charles

Machine info:

uname -a
Darwin rachel.geo.rpi.edu 8.6.0 Darwin Kernel Version 8.6.0: Tue Mar   
7 16:58:48 PST 2006; root:xnu-792.6.70.obj~1/RELEASE_PPC Power  
Macintosh powerpc

gcc-3.3 --version
gcc-3.3 (GCC) 3.3 20030304 (Apple Computer, Inc. build 1819)

I configured and built after using 'gcc_select 3.3'.

Configure command:
/Users/willic3/build/openmpi-1.0.2rc2r9567/configure --prefix=/Users/ 
willic3/geo
frame/tools/openmpi-gcc3.3 --disable-mpi-f90

I can also provide the configure and build logs if that will help.


Charles A. Williams
Dept. of Earth & Environmental Sciences
Science Center, 2C01B
Rensselaer Polytechnic Institute
Troy, NY  12180
Phone:    (518) 276-3369
FAX:        (518) 276-2012
e-mail:    willic3@rpi.edu



Charles A. Williams

Dept. of Earth & Environmental Sciences

Science Center, 2C01B

Rensselaer Polytechnic Institute

Troy, NY  12180

Phone:    (518) 276-3369

FAX:        (518) 276-2012

e-mail:    willic3@rpi.edu