I'm running Mac OS X v 10.3.9 Panther and tried to get OpenMPI to compile with IBM XLC and XLF. The compilation failed, any ideas what might be going wrong? I used the following settings:

export CC=/opt/ibmcmp/vacpp/6.0/bin/xlc
export CXX=/opt/ibmcmp/vacpp/6.0/bin/xlc++
export CFLAGS="-O3"
export CXXFLAGS="-O3"
export FFLAGS="-O3"
./configure --with-gm=/opt/gm --prefix=/home/warner/mpi_src/ompi102

ranlib .libs/libmpi_c_mpi.a
creating libmpi_c_mpi.la
(cd .libs && rm -f libmpi_c_mpi.la && ln -s ../libmpi_c_mpi.la libmpi_c_mpi.la)
Making all in cxx
source='mpicxx.cc' object='mpicxx.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/sh ../../.././config/depcomp \
/bin/sh ../../../libtool --tag=CXX --mode=compile /opt/ibmcmp/vacpp/6.0/bin/xlc++ -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include   -I../../../include -I../../.. -I../../.. -I../../../include -I../../../opal -I../../../orte -I../../../ompi  -D_REENTRANT  -DNDEBUG -O3  -c -o mpicxx.lo mpicxx.cc
mkdir .libs
/opt/ibmcmp/vacpp/6.0/bin/xlc++ -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include -I../../../include -I../../.. -I../../.. -I../../../include -I../../../opal -I../../../orte -I../../../ompi -D_REENTRANT -DNDEBUG -O3 -c mpicxx.cc  -qnocommon -DPIC -o .libs/mpicxx.o
"../../../ompi/mpi/cxx/group_inln.h", line 100.66: 1540-0216 (S) An expression of type "const int [][3]" cannot be converted to type "int (*)[3]".
"../../../ompi/mpi/cxx/group_inln.h", line 108.66: 1540-0216 (S) An expression of type "const int [][3]" cannot be converted to type "int (*)[3]".
make[3]: *** [mpicxx.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1


-Thanks and have an OpenMPI day!


Warner Yuen

Apple Computer

email: wyuen@apple.com

Tel: 408.718.2859

Fax: 408.715.0133