Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Problem moving from 1.4 to 1.6
From: Jeffrey A Cummings (Jeffrey.A.Cummings_at_[hidden])
Date: 2014-06-27 12:53:33


We have recently upgraded our cluster to a version of Linux which comes
with openMPI version 1.6.2.

An application which ran previously (using some version of 1.4) now errors
out with the following messages:

        librdmacm: Fatal: no RDMA devices found
        librdmacm: Fatal: no RDMA devices found
        librdmacm: Fatal: no RDMA devices found
 
--------------------------------------------------------------------------
        WARNING: Failed to open "OpenIB-cma" [DAT_INTERNAL_ERROR:].
        This may be a real error or it may be an invalid entry in the
uDAPL
        Registry which is contained in the dat.conf file. Contact your
local
        System Administrator to confirm the availability of the interfaces
in
        the dat.conf file.
 
--------------------------------------------------------------------------
        [tupile:25363] 2 more processes have sent help message
help-mpi-btl-udapl.txt / dat_ia_open fail
        [tupile:25363] Set MCA parameter "orte_base_help_aggregate" to 0
to see all help / error messages

The mpirun command line contains the argument '--mca btl ^openib', which I
thought told mpi to not look for the ib interface.

Can anyone suggest what the problem might be? Did the relevant syntax
change between versions 1.4 and 1.6?

Jeffrey A. Cummings
Engineering Specialist
Performance Modeling and Analysis Department
Systems Analysis and Simulation Subdivision
Systems Engineering Division
Engineering and Technology Group
The Aerospace Corporation
571-307-4220
jeffrey.a.cummings_at_[hidden]