Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.8.1 runs more OpenMP Threads on the same core
From: Luigi Santangelo (luigi.santangelo_at_[hidden])
Date: 2014-06-27 09:23:05


:) Thanks to both
I'll try you solution and I'll give you a feedback

Thanks

2014-06-27 15:01 GMT+02:00 <tmishima_at_[hidden]>:

>
>
> Hi Luigi,
>
> Please try:
>
> --map-by slot:pe=4
>
> Probably Ralph is very busy, so something sliped his memory...
>
> Regards,
> Tetsuya
>
> > Hi all,
> > My system is a 64 core, with Debian 3.2.57 64 bit, GNU gcc 4.7, kernel
> Linux 3.2.0 and OpenMPI 1.8.1.
> > I developed an application to matching proteins files using OpenMP
> +OpenMPI. I compiled souce code with -fopenmp flag, I set OMP_NUM_THREADS=4
> then I ran binary with mpiexec -np 16.
> > When the program runs, the top command show me that only 16 core are
> used. If I use the previous of OpenMPI (1.6.5) it works fine. Must I set
> anything in the new version? Where I wrong?
> >
> > Thanks in advance
> >
> > Luigi_______________________________________________
> > users mailing list
> > users_at_[hidden]
> > Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/usersLink to
> this post: http://www.open-mpi.org/community/lists/users/2014/06/24712.php
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/users
> Link to this post:
> http://www.open-mpi.org/community/lists/users/2014/06/24714.php
>