Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] poor performance using the openib btl
From: Maxime Boissonneault (maxime.boissonneault_at_[hidden])
Date: 2014-06-24 18:40:59


What are your threading options for OpenMPI (when it was built) ?

I have seen OpenIB BTL completely lock when some level of threading is
enabled before.

Maxime Boissonneault

Le 2014-06-24 18:18, Fischer, Greg A. a écrit :
>
> Hello openmpi-users,
>
> A few weeks ago, I posted to the list about difficulties I was having
> getting openib to work with Torque (see "openib segfaults with
> Torque", June 6, 2014). The issues were related to Torque imposing
> restrictive limits on locked memory, and have since been resolved.
>
> However, now that I've had some time to test the applications, I'm
> seeing abysmal performance over the openib layer. Applications run
> with the tcp btl execute about 10x faster than with the openib btl.
> Clearly something still isn't quite right.
>
> I tried running with "-mca btl_openib_verbose 1", but didn't see
> anything resembling a smoking gun. How should I go about determining
> the source of the problem? (This uses the same OpenMPI Version 1.8.1 /
> SLES11 SP3 / GCC 4.8.3 setup discussed previously.)
>
> Thanks,
>
> Greg
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/users
> Link to this post: http://www.open-mpi.org/community/lists/users/2014/06/24697.php

-- 
---------------------------------
Maxime Boissonneault
Analyste de calcul - Calcul Québec, Université Laval
Ph. D. en physique