Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] deprecated cuptiActivityEnqueueBuffer
From: jcabello_at_[hidden]
Date: 2014-06-16 13:40:07


Hi all:

I'm having trouble to compile OMPI from trunk svn with the new 6.0 nvidia
SDK because deprecated cuptiActivityEnqueueBuffer

this is the problem:

  CC libvt_la-vt_cupti_activity.lo
  CC libvt_la-vt_iowrap_helper.lo
  CC libvt_la-vt_libwrap.lo
  CC libvt_la-vt_mallocwrap.lo
vt_cupti_activity.c: In function 'vt_cuptiact_queueNewBuffer':
vt_cupti_activity.c:203:3: error: implicit declaration of function
'cuptiActivityEnqueueBuffer' [-Werror=implicit-function-declaration]
   VT_CUPTI_CALL(cuptiActivityEnqueueBuffer(cuCtx, 0, ALIGN_BUFFER(buffer,
8),

Does any body known any patch?