Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi linking problem
From: Marco Atzeri (marco.atzeri_at_[hidden])
Date: 2014-06-09 14:39:28


On 09/06/2014 19:14, Sergii Veremieiev wrote:
> Dear Sir/Madam,
>
> I'm trying to link a C/FORTRAN code on Cygwin with Open MPI 1.7.5 and
> GCC 4.8.2:
>
> mpicxx ./lib/Multigrid.o ./lib/GridFE.o ./lib/Data.o ./lib/GridFD.o
> ./lib/Parameters.o ./lib/MtInt.o ./lib/MtPol.o ./lib/MtDob.o -o
> Test_cygwin_openmpi_gcc -L./external/MUMPS/lib
> -ldmumps_cygwin_openmpi_gcc -lmumps_common_cygwin_openmpi_gcc
> -lpord_cygwin_openmpi_gcc -L./external/ParMETIS
> -lparmetis_cygwin_openmpi_gcc -lmetis_cygwin_openmpi_gcc
> -L./external/SCALAPACK -lscalapack_cygwin_openmpi_gcc
> -L./external/BLACS/LIB -lblacs-0_cygwin_openmpi_gcc
> -lblacsF77init-0_cygwin_openmpi_gcc -lblacsCinit-0_cygwin_openmpi_gcc
> -lblacs-0_cygwin_openmpi_gcc -L./external/BLAS -lblas_cygwin_openmpi_gcc
> -lmpi -lgfortran
>
> The following error messages are returned:
>
> ./external/MUMPS/lib/libdmumps_cygwin_openmpi_gcc.a(dmumps_part3.o): In
> function `dmumps_127_':
> /cygdrive/d/Sergey/Research/Codes/Thinfilmsolver/external/MUMPS/src/dmumps_part3.F:6068:
> undefined reference to `mpi_send_'

the fortran openmpi inteface is in libmpi_mpifh.dll.a

so try adding "-lmpi_mpifh" before "-lmpi -lgfortran"
and be sure to have libopenmpifh2-1.7.5-1 installed

> /cygdrive/d/Sergey/Research/Codes/Thinfilmsolver/external/MUMPS/src/dmumps_part3.F:6068:(.text+0x1d3):
> relocation truncated to fit: R_X86_64_PC32 against undefined symbol
> `mpi_send_'

this could be a side effect, but it could also be a complete
different issue

>
>
> Could you please advise me what further libraries should I include on
> linking? Thank you.
>
> Best regards,
>
> Sergii
>

Regards
MArco