Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] --preload-binary does not work
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-06-06 20:34:11


Looks like there is some strange interaction there, but I doubt I'll get around to fixing it soon unless someone has a burning reason to not use tree spawn when preloading binaries. I'll mark it down as something to look at as time permits.

On Jun 6, 2014, at 4:28 PM, Ralph Castain <rhc_at_[hidden]> wrote:

> Don't know - I haven't seen someone use that option in awhile. Is there some reason to do so?
>
> On Jun 6, 2014, at 3:44 PM, E.O. <ooyama.eiichi_at_[hidden]> wrote:
>
>> Thank you!
>> With the patch, --preload-binary option is working fine.
>> However, if I add "--gmca plm_rsh_no_tree_spawn 1" as a mpirun command line option, it hangs.
>>
>> # /mpi/bin/mpirun --allow-run-as-root --gmca plm_rsh_no_tree_spawn 1 --preload-binary --hostfile /root/.hosts --prefix /mpi --np 120 a.out
>>
>> If I ran the command without --preload-binary, it works fine (have to copy the binary to each node beforehand of course). I guess this is a different issue?
>>
>> Eiichi
>>
>>
>> eiichi
>>
>>
>>
>> On Fri, Jun 6, 2014 at 5:35 PM, Ralph Castain <rhc_at_[hidden]> wrote:
>> Okay, I found the problem and think I have a fix that I posted (copied EO on it). You are welcome to download the patch and try it. Scheduled for release in 1.8.2
>>
>> Thanks
>> Ralph
>>
>>
>> On Jun 6, 2014, at 1:01 PM, Ralph Castain <rhc_at_[hidden]> wrote:
>>
>>> Yeah, it doesn't require ssh any more - but I haven't tested it in a bit, and so it's possible something crept in there.
>>>
>>> On Jun 6, 2014, at 12:27 PM, Reuti <reuti_at_[hidden]> wrote:
>>>
>>>> Am 06.06.2014 um 21:04 schrieb Ralph Castain:
>>>>
>>>>> Supposed to, yes - but I don't know how much testing it has seen. I can try to take a look
>>>>
>>>> Wasn't it on the list recently, that 1.8.1 should do it even without passphraseless SSH between the nodes?
>>>>
>>>> -- Reuti
>>>>
>>>>
>>>>> On Jun 6, 2014, at 12:02 PM, E.O. <ooyama.eiichi_at_[hidden]> wrote:
>>>>>
>>>>>> Hello
>>>>>> I am using OpenMPI ver 1.8.1 on a cluster of 4 machines.
>>>>>> One Redhat 6.2 and three busybox machine. They are all 64bit environment.
>>>>>>
>>>>>> I want to use --preload-binary option to send the binary file to hosts but it's not working.
>>>>>>
>>>>>> # /mpi/bin/mpirun --prefix /mpi --preload-files ./a.out --allow-run-as-root --np 4 --host box0101,box0103 --preload-binary ./a.out
>>>>>> --------------------------------------------------------------------------
>>>>>> mpirun was unable to launch the specified application as it could not access
>>>>>> or execute an executable:
>>>>>>
>>>>>> Executable: ./a.out
>>>>>> Node: box0101
>>>>>>
>>>>>> while attempting to start process rank 17.
>>>>>> --------------------------------------------------------------------------
>>>>>> 17 total processes failed to start
>>>>>> #
>>>>>>
>>>>>> If I sent the binary by SCP beforehand, the command works fine. SCP is working fine without password between the hosts.
>>>>>> Is the option supposed to work?
>>>>>> Thank you,
>>>>>>
>>>>>> Eiichi
>>>>>>
>>>>>> _______________________________________________
>>>>>> users mailing list
>>>>>> users_at_[hidden]
>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>