Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] --preload-binary does not work
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-06-06 16:01:05


Yeah, it doesn't require ssh any more - but I haven't tested it in a bit, and so it's possible something crept in there.

On Jun 6, 2014, at 12:27 PM, Reuti <reuti_at_[hidden]> wrote:

> Am 06.06.2014 um 21:04 schrieb Ralph Castain:
>
>> Supposed to, yes - but I don't know how much testing it has seen. I can try to take a look
>
> Wasn't it on the list recently, that 1.8.1 should do it even without passphraseless SSH between the nodes?
>
> -- Reuti
>
>
>> On Jun 6, 2014, at 12:02 PM, E.O. <ooyama.eiichi_at_[hidden]> wrote:
>>
>>> Hello
>>> I am using OpenMPI ver 1.8.1 on a cluster of 4 machines.
>>> One Redhat 6.2 and three busybox machine. They are all 64bit environment.
>>>
>>> I want to use --preload-binary option to send the binary file to hosts but it's not working.
>>>
>>> # /mpi/bin/mpirun --prefix /mpi --preload-files ./a.out --allow-run-as-root --np 4 --host box0101,box0103 --preload-binary ./a.out
>>> --------------------------------------------------------------------------
>>> mpirun was unable to launch the specified application as it could not access
>>> or execute an executable:
>>>
>>> Executable: ./a.out
>>> Node: box0101
>>>
>>> while attempting to start process rank 17.
>>> --------------------------------------------------------------------------
>>> 17 total processes failed to start
>>> #
>>>
>>> If I sent the binary by SCP beforehand, the command works fine. SCP is working fine without password between the hosts.
>>> Is the option supposed to work?
>>> Thank you,
>>>
>>> Eiichi
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users