Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] --preload-binary does not work
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-06-06 15:04:07


Supposed to, yes - but I don't know how much testing it has seen. I can try to take a look

On Jun 6, 2014, at 12:02 PM, E.O. <ooyama.eiichi_at_[hidden]> wrote:

> Hello
> I am using OpenMPI ver 1.8.1 on a cluster of 4 machines.
> One Redhat 6.2 and three busybox machine. They are all 64bit environment.
>
> I want to use --preload-binary option to send the binary file to hosts but it's not working.
>
> # /mpi/bin/mpirun --prefix /mpi --preload-files ./a.out --allow-run-as-root --np 4 --host box0101,box0103 --preload-binary ./a.out
> --------------------------------------------------------------------------
> mpirun was unable to launch the specified application as it could not access
> or execute an executable:
>
> Executable: ./a.out
> Node: box0101
>
> while attempting to start process rank 17.
> --------------------------------------------------------------------------
> 17 total processes failed to start
> #
>
> If I sent the binary by SCP beforehand, the command works fine. SCP is working fine without password between the hosts.
> Is the option supposed to work?
> Thank you,
>
> Eiichi
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users