Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] intel compiler and openmpi 1.8.1
From: Joshua Ladd (jladd.mlnx_at_[hidden])
Date: 2014-05-29 09:22:04


Lorenzo,

set

$> export PATH=/Users/lorenzodona/
Documents/openmpi-1.8.1/bin:$PATH

$> export LD_LIBRARY_PATH=/Users/lorenzodona/
Documents/openmpi-1.8.1/lib:$LD_LIBRARY_PATH

Then try.

Josh

On Thu, May 29, 2014 at 9:04 AM, Ralph Castain <rhc_at_[hidden]> wrote:

> Are you sure you have /Users/lorenzodona/Documents/openmpi-1.8.1/bin at
> the *beginning* of your PATH?
>
> Reason: most common cause of what you are showing is that you are picking
> up some other version of mpif90
>
>
> On May 29, 2014, at 4:11 AM, Lorenzo Donà <lorechimica91_at_[hidden]>
> wrote:
>
> I compiled openmpi 1.8.1 with intel compiler with this conf.
> ./configure FC=ifort CC=icc CXX=icpc
> --prefix=/Users/lorenzodona/Documents/openmpi-1.8.1/
> but when i write mpif90 -v i found:
> Using built-in specs.
> COLLECT_GCC=/opt/local/bin/gfortran-mp-4.8
>
> COLLECT_LTO_WRAPPER=/opt/local/libexec/gcc/x86_64-apple-darwin13/4.8.2/lto-wrapper
> Target: x86_64-apple-darwin13
> Configured with:
> /opt/local/var/macports/build/_opt_mports_dports_lang_gcc48/gcc48/work/gcc-4.8.2/configure
> --prefix=/opt/local --build=x86_64-apple-darwin13
> --enable-languages=c,c++,objc,obj-c++,lto,fortran,java
> --libdir=/opt/local/lib/gcc48 --includedir=/opt/local/include/gcc48
> --infodir=/opt/local/share/info --mandir=/opt/local/share/man
> --datarootdir=/opt/local/share/gcc-4.8 --with-local-prefix=/opt/local
> --with-system-zlib --disable-nls --program-suffix=-mp-4.8
> --with-gxx-include-dir=/opt/local/include/gcc48/c++/ --with-gmp=/opt/local
> --with-mpfr=/opt/local --with-mpc=/opt/local --with-cloog=/opt/local
> --enable-cloog-backend=isl --disable-cloog-version-check
> --enable-stage1-checking --disable-multilib --enable-lto
> --enable-libstdcxx-time --with-as=/opt/local/bin/as
> --with-ld=/opt/local/bin/ld --with-ar=/opt/local/bin/ar --with-bugurl=
> https://trac.macports.org/newticket --with-pkgversion='MacPorts gcc48
> 4.8.2_0'
> Thread model: posix
> gcc version 4.8.2 (MacPorts gcc48 4.8.2_0)
>
> and —-version i found:
> GNU Fortran (MacPorts gcc48 4.8.2_0) 4.8.2
> Copyright (C) 2013 Free Software Foundation, Inc.
>
> GNU Fortran comes with NO WARRANTY, to the extent permitted by law.
> You may redistribute copies of GNU Fortran
> under the terms of the GNU General Public License.
> For more information about these matters, see the file named COPYING
>
> So I think that is not compiled with intel compiler please can you help me.
> thanks thanks a lot for your patience and to help me
> Dearly lorenzo
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>