Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi configuration error?
From: Douglas L Reeder (dlr1_at_[hidden])
Date: 2014-05-16 17:58:04


Ben,

You might want to use module (source forge) to manage paths to different mpi implementations. It is fairly easy to set up and very robust for this type of problem. You would remove contentious application paths from you standard PATH and then use module to switch them in and out as needed.

Doug Reeder
On May 16, 2014, at 3:39 PM, Ben Lash <bl10_at_[hidden]> wrote:

> My cluster has just upgraded to a new version of MPI, and I'm using an old one. It seems that I'm having trouble compiling due to the compiler wrapper file moving (full error here: http://pastebin.com/EmwRvCd9)
> "Cannot open configuration file /opt/apps/openmpi/1.4.4-intel/share/openmpi/mpif90-wrapper-data.txt"
>
> I've found the file on the cluster at /opt/apps/openmpi/retired/1.4.4-intel/share/openmpi/mpif90-wrapper-data.txt
> How do I tell the old mpi wrapper where this file is?
> I've already corrected one link to mpich -> /opt/apps/openmpi/retired/1.4.4-intel/, which is in the software I'm trying to recompile's lib folder (/home/bl10/CMAQv5.0.1/lib/x86_64/ifort). Thanks for any ideas. I also tried changing $pkgdatadir based on what I read here:
> http://www.open-mpi.org/faq/?category=mpi-apps#default-wrapper-compiler-flags
>
> Thanks.
>
> --Ben L
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users