Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Build failure on scientific linux 5.4
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-05-14 19:18:14


Just sniffing around the web, I found that this is a problem caused by newer versions of gcc. One reporter stated that they resolved the problem by adding "-fgnu89-inline" to their configuration:

"add the compiler flag "-fgnu89-inline" (because of an issue where old glibc libraries aren't compatible with "the c99 standard"). I added the compilation flag (adding it just after the "-std=gnu99" option) and the compilation errors went away."

On May 14, 2014, at 2:17 PM, Jack Stalnaker <jack.stalnaker_at_[hidden]> wrote:

> I am having the same compile time failure mentioned on the devel group here:
>
> http://www.open-mpi.org/community/lists/devel/2014/02/14221.php
>
> In short, the compilation of romio fails with errors about redefinition of lstat64, I am attaching the requested configuration and make outputs. Can anyone help? No one responded to the linked message above.
>
> Compiling using gcc 4.8.2, which is not the system compiler.
>
> Thanks
> --Jack
> <config.out.bz2><make.out.bz2>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users