Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Error in openmpi-1.8.2a1r31556 with Sun C 5.12
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2014-04-30 10:40:26


Hi,

I tried to install openmpi-1.8.2a1r31556 on my machines (openSUSE
Linux 12.1 x86_64, Solaris 10 x86_64, and Solaris 10 Sparc) with
"Sun C 5.12" and got the following error on all platforms.

tyr openmpi-1.8.2a1r31556-Linux.x86_64.64_cc 131 tail -15 log.make.Linux.x86_64.64_cc
  PPFC comm_compare_f08.lo
  PPFC comm_connect_f08.lo
  PPFC comm_create_errhandler_f08.lo

   fn = c_funloc(comm_errhandler_fn)
                 ^
"../../../../../openmpi-1.8.2a1r31556/ompi/mpi/fortran/use-mpi-f08/comm_create_errhandler_f08.F90",
  Line = 22, Column = 18: ERROR: C_FUNLOC function argument must
  be a procedure that is interoperable or a procedure pointer
  associated with an interoperable procedure.

f90comp: 193 SOURCE LINES
f90comp: 1 ERRORS, 0 WARNINGS, 0 OTHER MESSAGES, 0 ANSI
make[2]: *** [comm_create_errhandler_f08.lo] Error 1
make[2]: Leaving directory `.../ompi/mpi/fortran/use-mpi-f08'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `.../ompi'
make: *** [all-recursive] Error 1
tyr openmpi-1.8.2a1r31556-Linux.x86_64.64_cc 132

I configured with the following command.

../openmpi-1.8.2a1r31556/configure --prefix=/usr/local/openmpi-1.8.2_64_cc \
  --libdir=/usr/local/openmpi-1.8.2_64_cc/lib64 \
  --with-jdk-bindir=/usr/local/jdk1.8.0/bin \
  --with-jdk-headers=/usr/local/jdk1.8.0/include \
  JAVA_HOME=/usr/local/jdk1.8.0 \
  LDFLAGS="-m64" \
  CC="cc" CXX="CC" FC="f95" \
  CFLAGS="-m64" CXXFLAGS="-m64 -library=stlport4" FCFLAGS="-m64" \
  CPP="cpp" CXXCPP="cpp" \
  CPPFLAGS="" CXXCPPFLAGS="" \
  --enable-mpi-cxx \
  --enable-cxx-exceptions \
  --enable-mpi-java \
  --enable-heterogeneous \
  --enable-mpi-thread-multiple \
  --with-threads=posix \
  --with-hwloc=internal \
  --without-verbs \
  --with-wrapper-cflags=-m64 \
  --enable-debug \
  |& tee log.configure.$SYSTEM_ENV.$MACHINE_ENV.64_cc

I would be grateful if somebody could solve the problem. Thank
you very much for any help in advance.

Kind regards

Siegmar