Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.8 and PGI compilers
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-04-25 13:26:22


Hmmm....we haven't heard a problem like that, but if you don't have Xeon Phi devices on your machine, one simple workaround would be to add

--enable-mca-no-build=btl-scif

to your configure line

On Apr 25, 2014, at 10:22 AM, Andrus, Brian Contractor <bdandrus_at_[hidden]> wrote:

> All,
>
> I have been unable to compile OpenMPI 1.8 using PGI compilers (13.6, 13.10 or 14.3)
>
> EVERY time, I get the error:
>
> PGC-S-0094-Illegal type conversion required (btl_scif_component.c: 215)
> PGC/x86-64 Linux 14.3-0: compilation completed with severe errors
> make[2]: *** [btl_scif_component.lo] Error 1
>
>
> Has anyone successfully built OpenMPI 1.8 with PGI?
>
> If so, how??
> I have tried ./configure alone, using "-fast" options, setting -DNO_PGI_OFFSET all to no avail.
>
> Thanks in advance,
>
>
> Brian Andrus
> ITACS/Research Computing
> Naval Postgraduate School
> Monterey, California
> voice: 831-656-6238
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users