Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open Mpi execution error
From: Kamal Selvam (infikamal5_at_[hidden])
Date: 2014-04-07 12:56:35


Thanks a lot for your help, It worked finally.

On Mon, Apr 7, 2014 at 6:05 PM, Ralph Castain <rhc_at_[hidden]> wrote:

> Deleting the install as you describe is a VERY bad idea. As I explained
> elsewhere, the system generally comes with an installation. Blowing things
> away can destabilize other areas of the system unless you are (a) very
> careful, and (b) very lucky
>
> Just stay away from the system directories, please.
>
>
> On Apr 7, 2014, at 8:50 AM, Hamid Saeed <e.hamidsaeed_at_[hidden]> wrote:
>
> make -j<number of processors you want to assign for the make>
>
>
> It is very simple to uninstall
>
> go to the
> /usr/local/
> here you will find
> lib,bin etc these are the file of MPI.
> just type
> rm -r <name of the file>
>
> and also next time when you want to install i will recommend you use
>
> ./configure --prefix=/usr/local/mpi_installation
> make -j2
> make install
>
> include the following lines in your .bashrc file.
>
> export PATH=/usr/local/mpi_installation/bin:$PATH
> export LD_LIBRARY_PATH=
> /usr/local/mpi_installation/lib:$LD_LIBRARY_PATH
>
> best of luck.
>
>
> On Sun, Apr 6, 2014 at 5:45 PM, Kamal <infikamal5_at_[hidden]> wrote:
>
>> Hi Ralph,
>>
>> I use OMPI 1.8 for Macbook OS X mavericks.
>>
>> As you said I will create a new directory to install my MPI files.
>>
>> Thanks for your reply,
>>
>> Kamal.
>>
>> On 07/04/2014 17:37, Ralph Castain wrote:
>>
>> What version of OMPI are you attempting to install?
>>
>> Also, using /usr/local as your prefix is a VERY, VERY BAD idea. Most OS
>> distributions come with a (typically old) version of OMPI installed in the
>> system area. Overlaying that with another version can easily lead to the
>> errors you show.
>>
>> You should always install to a user-level directory and then set your
>> path and ld_library_path to start with that location
>>
>>
>> On Apr 6, 2014, at 8:30 AM, Kamal <infikamal5_at_[hidden]> wrote:
>>
>> Hello Open MPI,
>>
>> I installed open-mpi with
>> ./configure --prefix=/usr/local/
>> make all
>> make install
>>
>> then I launched my sample code which gave me this error
>> my LD_LIBRARY_PATH=/usr/local/
>>
>> I have attached the output file with this mail
>> could some one please help me with this .
>>
>>
>> Thanks,
>>
>> Kamal
>>
>>
>> <out.txt>_______________________________________________
>>
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>>
>> _______________________________________________
>> users mailing listusers_at_[hidden]http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
>
> --
> _______________________________________________
> Hamid Saeed
> CoSynth GmbH & Co. KG
> Escherweg 2 - 26121 Oldenburg - Germany
> Tel +49 441 9722 738 | Fax -278
> http://www.cosynth.com
> _______________________________________________
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>