Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Openmpi 1.8 "rmaps seq" doesn't work
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-04-07 11:42:26


Looks like bit-rot has struck the sequential mapper support - I'll revive it for 1.8.1

On Apr 6, 2014, at 7:17 PM, Chen Bill <billchen001_at_[hidden]> wrote:

> Hi ,
>
> I just tried the openmpi 1.8, but I found the feature --mca rmaps seq doesn't work.
>
> for example,
>
> >mpirun -np 4 -hostfile hostsfle --mca rmaps seq hostname
>
> It shows below error,
>
> --------------------------------------------------------------------------
> Your job failed to map. Either no mapper was available, or none
> of the available mappers was able to perform the requested
> mapping operation. This can happen if you request a map type
> (e.g., loadbalance) and the corresponding mapper was not built.
> --------------------------------------------------------------------------
>
> but when I use ompi_info ,it shows has this feature
>
>
> >ompi_info |grep -i rmaps
> MCA rmaps: lama (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: mindist (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: ppr (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: rank_file (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: resilient (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: round_robin (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: seq (MCA v2.0, API v2.0, Component v1.8)
> MCA rmaps: staged (MCA v2.0, API v2.0, Component v1.8)
>
> Any suggestions?
>
> Many thanks,
> Bill
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users