Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] usNIC point-to-point messaging module
From: Dave Goodell (dgoodell) (dgoodell_at_[hidden])
Date: 2014-04-01 16:08:10


On Apr 1, 2014, at 12:13 PM, Filippo Spiga <spiga.filippo_at_[hidden]> wrote:

> Dear Ralph, Dear Jeff,
>
> I've just recompiled the latest Open MPI 1.8. I added "--enable-mca-no-build=btl-usnic" to configure but the message still appear. Here the output of "--mca btl_base_verbose 100" (trunked immediately after the application starts)

Jeff's on vacation, so I'll see if I can help here.

Try deleting all the files in "$PREFIX/lib/openmpi/", where "$PREFIX" is the value you passed to configure with "--prefix=". If you did not pass a value, then it is "/usr/local". Then reinstall (with "make install" in the OMPI build tree).

What I think is happening is that you still have an "mca_btl_usnic.so" file leftover from the last time you installed OMPI (before passing "--enable-mca-no-build=btl-usnic"). So OMPI is using this shared library and you get exactly the same problem.

-Dave