Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Help building/installing a working Open MPI 1.7.4 on OS X 10.9.2 with Free PGI Fortran
From: Matt Thompson (fortran_at_[hidden])
Date: 2014-03-24 19:27:20


Jeff,

I ran these commands:

$ make clean
$ make distclean

(wanted to be extra sure!)

$ ./configure CC=gcc CXX=g++ F77=pgfortran FC=pgfortran CFLAGS='-m64'
CXXFLAGS='-m64' LDFLAGS='-m64' FCFLAGS='-m64' FFLAGS='-m64'
--prefix=/Users/fortran/AutomakeBug/autobug14 | & tee configure.log
$ make V=1 install |& tee makeV1install.log

So find attached the config.log, configure.log, and makeV1install.log which
should have all the info you asked about.

Matt

PS: I just tried configure/make/make install with Open MPI 1.7.5, but the
same error occurs as expected. Hope springs eternal, you know?

On Mon, Mar 24, 2014 at 6:48 PM, Jeff Squyres (jsquyres) <jsquyres_at_[hidden]
> wrote:

> On Mar 24, 2014, at 6:34 PM, Matt Thompson <fortran_at_[hidden]> wrote:
>
> > Sorry for the late reply. The answer is: No, 1.14.1 has not fixed the
> problem (and indeed, that's what my Mac is running):
> >
> > (28) $ make install | & tee makeinstall.log
> > Making install in src
> > ../config/install-sh -c -d '/Users/fortran/AutomakeBug/autobug14/lib'
> > /bin/sh ../libtool --mode=install /usr/bin/install -c
> libfortran_stuff.la '/Users/fortran/AutomakeBug/autobug14/lib'
> > libtool: install: /usr/bin/install -c .libs/libfortran_stuff.0.dylib
> /Users/fortran/AutomakeBug/autobug14/lib/libfortran_stuff.0.dylib
> > install: .libs/libfortran_stuff.0.dylib: No such file or directory
> > make[2]: *** [install-libLTLIBRARIES] Error 71
> > make[1]: *** [install-am] Error 2
> > make: *** [install-recursive] Error 1
> >
> > This is the output from either the am12 or am14 test. If you have any
> options you'd like me to try with this, let me know. (For example, is there
> a way to make autotools *more* verbose? I've always tried to make it less
> so!)
>
> Ok. With the am14 tarball, please run:
>
> make clean
>
> And then run this:
>
> make V=1 install
>
> And then send the following:
>
> - configure stdout
> - config.log file
> - stdout/stderr from "make V=1 install"
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
"And, isn't sanity really just a one-trick pony anyway? I mean all you
 get is one trick: rational thinking. But when you're good and crazy,
 oooh, oooh, oooh, the sky is the limit!" -- The Tick