Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI job initializing problem
From: Noam Bernstein (noam.bernstein_at_[hidden])
Date: 2014-03-20 14:29:19


On Mar 20, 2014, at 2:13 PM, Ralph Castain <rhc_at_[hidden]> wrote:

>
> On Mar 20, 2014, at 9:48 AM, Beichuan Yan <beichuan.yan_at_[hidden]> wrote:
>
>> Hi,
>>
>> Today I tested OMPI v1.7.5rc5 and surprisingly, it works like a charm!
>>
>> I found discussions related to this issue:
>>
>> 1. http://www.open-mpi.org/community/lists/users/2011/11/17688.php
>> The correct solution here is get your sys admin to make /tmp local. Making /tmp NFS mounted across multiple nodes is a major "faux pas" in the Linux world - it should never be done, for the reasons stated by Jeff.
>>
>> my comment: for most clusters I have used, /tmp is NOT local. Open MPI community may not enforce it.
>
> We don't enforce anything, but /tmp being network mounted is a VERY unusual situation in the cluster world, and highly unrecommended

Note that spirit is not a “cluster”, at least not the way that word is usually used in the HPC world. It’s an SGI ICE X, which uses Linux nodes and infiniband, like many HPC clusters, but is designed by SGI to be in some ways more like their previous, more tightly-coupled, machines.

                                                                                Noam


  • application/pkcs7-signature attachment: smime.p7s