Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Help building/installing a working Open MPI 1.7.4 on OS X 10.9.2 with Free PGI Fortran
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-03-20 06:45:10


Sorry for the delay; we're working on releasing 1.7.5 and that's consuming all my time...

That's a strange error. Can you confirm whether ompi_buil_dir/ompi/mpi/fortran/use-mpi-ignore-tkr/.libs/libmpi_usempi_ignore_tkr.0.dylib exists or not?

Can you send all the info listed here:

    http://www.open-mpi.org/community/help/

On Mar 18, 2014, at 8:59 PM, Matt Thompson <fortran_at_[hidden]> wrote:

> All,
>
> I recently downloaded PGI's Free OS X Fortran compiler:
>
> http://www.pgroup.com/products/freepgi/
>
> in the hope of potentially using it to compile a weather model I work with GEOS-5. That model requires an MPI stack and I usually start (and end) with Open MPI on a desktop.
>
> So, I grabbed Open MPI 1.7.4 and tried compiling it in a few ways. In each case, my C and C++ compilers were the built-in clang-y gcc and g++ from Xcode, while pgfortran was the Fortran compiler. I tried a few different configures from the basic:
>
> $ ./configure CC=gcc CXX=g++ F77=pgfortran FC=pgfortran CFLAGS='-m64' CXXFLAGS='-m64' FCFLAGS='-m64' FFLAGS='-m64' --prefix=/Users/fortran/MPI/openmpi_1.7.4-pgi_14.3
>
> all the way to the "let's try every flag Google says I might use" version of:
>
> $ ./configure CC=gcc CXX=g++ F77=pgfortran FC=pgfortran CFLAGS='-m64 -Xclang -target-feature -Xclang -aes -mmacosx-version-min=10.8' CXXFLAGS='-m64 -Xclang -target-feature -Xclang -aes -mmacosx-version-min=10.8' LDFLAGS='-m64' FCFLAGS='-m64' FFLAGS='-m64' --prefix=/Users/fortran/MPI/openmpi_1.7.4-pgi_14.3-gcc-mmacosx
>
> In every case, the configure, make, and make check worked well without error, but running a 'make install' led to:
>
> Making install in mpi/fortran/use-mpi-ignore-tkr
> ../../../../config/install-sh -c -d '/Users/fortran/MPI/openmpi_1.7.4-pgi_14.3-gcc-mmacosx/lib'
> /bin/sh ../../../../libtool --mode=install /usr/bin/install -c libmpi_usempi_ignore_tkr.la '/Users/fortran/MPI/openmpi_1.7.4-pgi_14.3-gcc-mmacosx/lib'
> libtool: install: /usr/bin/install -c .libs/libmpi_usempi_ignore_tkr.0.dylib /Users/fortran/MPI/openmpi_1.7.4-pgi_14.3-gcc-mmacosx/lib/libmpi_usempi_ignore_tkr.0.dylib
> install: .libs/libmpi_usempi_ignore_tkr.0.dylib: No such file or directory
> make[3]: *** [install-libLTLIBRARIES] Error 71
> make[2]: *** [install-am] Error 2
> make[1]: *** [install-recursive] Error 1
> make: *** [install-recursive] Error 1
>
> Any ideas on how to overcome this?
>
> Thanks,
> Matt Thompson
> --
> "And, isn't sanity really just a one-trick pony anyway? I mean all you
> get is one trick: rational thinking. But when you're good and crazy,
> oooh, oooh, oooh, the sky is the limit!" -- The Tick
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/