Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Compiling Open MPI 1.7.4 using PGI 14.2 and Mellanox HCOLL enabled
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-03-17 10:54:02


Ralph -- it seems to be picking up "-pthread" from libslurm.la (i.e., outside of the OMPI tree), which pgcc doesn't seem to like.

Another solution might be to (temporarily?) remove the "-pthread" from libslurm.la (which is a text file that you can edit). Then OMPI shouldn't pick up that flag, and building should be ok.

On Mar 16, 2014, at 11:50 AM, Ralph Castain <rhc_at_[hidden]> wrote:

> If you are running on a Slurm-managed cluster, it won't be happy without configuring --with-slurm - you won't see the allocation, for one.
>
> Is it just the --with-slurm option that causes the problem? In other words, if you remove the rest of those options (starting --with-hcoll and going down that config line) and leave --with-slurm, does it build?
>
> On Mar 16, 2014, at 8:22 AM, Filippo Spiga <spiga.filippo_at_[hidden]> wrote:
>
>> Hi Jeff, Hi Ake,
>>
>> removing --with-slurm and keeping --with-hcoll seems to work. The error disappears at compile time, I have not yet tried to run a job. I can copy config.log and the make.log is needed.
>>
>> Cheers,
>> F
>>
>> On Mar 11, 2014, at 4:48 PM, Jeff Squyres (jsquyres) <jsquyres_at_[hidden]> wrote:
>>> On Mar 11, 2014, at 11:22 AM, Åke Sandgren <ake.sandgren_at_[hidden]> wrote:
>>>
>>>>>> ../configure CC=pgcc CXX=pgCC FC=pgf90 F90=pgf90 --prefix=/usr/local/Cluster-Users/fs395/openmpi-1.7.4/pgi-14.2_cuda-6.0RC --enable-mpirun-prefix-by-default --with-hcoll=$HCOLL_DIR --with-fca=$FCA_DIR --with-mxm=$MXM_DIR --with-knem=$KNEM_DIR --with-slurm=/usr/local/Cluster-Apps/slurm --with-cuda=$CUDA_INSTALL_PATH
>>>>>>
>>>>>>
>>>>>> At some point the compile process fails with this error:
>>>>>>
>>>>>> make[2]: Leaving directory `/home/fs395/archive/openmpi-1.7.4/build/ompi/mca/coll/hierarch'
>>>>>> Making all in mca/coll/hcoll
>>>>>> make[2]: Entering directory `/home/fs395/archive/openmpi-1.7.4/build/ompi/mca/coll/hcoll'
>>>>>> CC coll_hcoll_module.lo
>>>>>> CC coll_hcoll_component.lo
>>>>>> CC coll_hcoll_rte.lo
>>>>>> CC coll_hcoll_ops.lo
>>>>>> CCLD mca_coll_hcoll.la
>>>>>> pgcc-Error-Unknown switch: -pthread
>>>>
>>>> You have to remove the -pthread from inherited_linker_flags=
>>>> in libpmi.la libslurm.la from your slurm build.
>>>
>>> With the configure line given above, I don't think he should be linking against libslurm.
>>>
>>> But I wonder if the underlying issue is actually correct: perhaps the inherited_linker_flags from libhcoll.la has -pthreads in it.
>>
>>
>> --
>> Mr. Filippo SPIGA, M.Sc.
>> http://www.linkedin.com/in/filippospiga ~ skype: filippo.spiga
>>
>> «Nobody will drive us out of Cantor's paradise.» ~ David Hilbert
>>
>> *****
>> Disclaimer: "Please note this message and any attachments are CONFIDENTIAL and may be privileged or otherwise protected from disclosure. The contents are not to be disclosed to anyone other than the addressee. Unauthorized recipients are requested to preserve this confidentiality and to advise the sender immediately of any error in transmission."
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/